summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-02-16 12:54:54 -0500
committerCarlos Aznarán2024-02-16 12:54:54 -0500
commit9a25501285aa9176aaff552a231217c6fe32ab48 (patch)
tree588fb6cfc6f384320bc7d8582c811fa6b251b3bd
parent969d174c5df33a7a9ee354aa0bc35af9c7c5da22 (diff)
downloadaur-9a25501285aa9176aaff552a231217c6fe32ab48.tar.gz
Bump version to 5.6.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD53
2 files changed, 28 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aef59adf1bc5..94e02700d230 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = python-oct2py
- pkgdesc = Python to GNU Octave bridge.
- pkgver = 5.5.1
+ pkgdesc = Python to GNU Octave bridge --> run m-files from python
+ pkgver = 5.6.0
pkgrel = 1
url = http://github.com/blink1073/oct2py
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-hatchling
+ makedepends = python-wheel
depends = python-scipy
- depends = python-numpy
depends = jupyter-octave_kernel
depends = gnuplot
optdepends = python-pytest: for test use
optdepends = python-pandas: for test use
optdepends = jupyter-nbconvert: for test use
- optdepends = python-sphinx: documentation support
- optdepends = python-sphinx-bootstrap-theme
- optdepends = python-numpydoc: documentation support
- source = https://files.pythonhosted.org/packages/source/o/oct2py/oct2py-5.5.1.tar.gz
- b2sums = c0a645464b64d04137f53f3c15bcd90d1df193d7dd7e955cf1e90b5d279091cc16b3052321a1788b6a382ad8759db1619b0a20d117c627d88abe75d13aeb62e3
+ source = https://pypi.org/packages/source/o/oct2py/oct2py-5.6.0.tar.gz
+ b2sums = e22aca80608e1132f2cb8936e9dac7c97bd8e5463b6997dd80f0ed567af2a59a28b4c58995b11e2c1a970bc0bde81afda432d8ce5306b2eb5417b1f75b8b4b19
pkgname = python-oct2py
diff --git a/PKGBUILD b/PKGBUILD
index e028bf1942fb..a8843711137d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,29 @@
-#!/bin/bash
-
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
# Maintainer: PumpkinCheshire <me at pumpkincheshire dot com>
# Contributor: Ishan Arora <ishanarora@gmail.com>
-
-_name=oct2py
-pkgname=python-oct2py
-pkgver=5.5.1
+_base=oct2py
+pkgname=python-${_base}
+pkgver=5.6.0
pkgrel=1
-pkgdesc="Python to GNU Octave bridge."
-arch=('any')
-url="http://github.com/blink1073/oct2py"
-license=('MIT')
-depends=(
- 'python-scipy'
- 'python-numpy'
- 'jupyter-octave_kernel'
- 'gnuplot')
-optdepends=(
- 'python-pytest: for test use'
- 'python-pandas: for test use'
- 'jupyter-nbconvert: for test use'
- 'python-sphinx: documentation support'
- 'python-sphinx-bootstrap-theme'
- 'python-numpydoc: documentation support'
-)
-makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-b2sums=('c0a645464b64d04137f53f3c15bcd90d1df193d7dd7e955cf1e90b5d279091cc16b3052321a1788b6a382ad8759db1619b0a20d117c627d88abe75d13aeb62e3')
+pkgdesc="Python to GNU Octave bridge --> run m-files from python"
+arch=(any)
+url="http://github.com/blink1073/${_base}"
+license=(MIT)
+depends=(python-scipy jupyter-octave_kernel gnuplot)
+makedepends=(python-build python-installer python-setuptools python-hatchling python-wheel)
+optdepends=('python-pytest: for test use'
+ 'python-pandas: for test use'
+ 'jupyter-nbconvert: for test use')
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
+b2sums=('e22aca80608e1132f2cb8936e9dac7c97bd8e5463b6997dd80f0ed567af2a59a28b4c58995b11e2c1a970bc0bde81afda432d8ce5306b2eb5417b1f75b8b4b19')
build() {
- cd "$srcdir/$_name-$pkgver" || exit
-
- python -m build --wheel --no-isolation
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
- cd "$srcdir/$_name-$pkgver" || exit
- python -m installer --destdir="$pkgdir" dist/*.whl
-
- # install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/python-$_name/LICENSE"
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
}