summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConnor Behan2015-06-08 17:09:20 -0400
committerConnor Behan2015-06-08 17:09:20 -0400
commit9a2639576152d1d7cf45a6ce5c7cea65ba659afe (patch)
tree3d0f748fe928b5ca0c2f4c7147ed14d81749784f
downloadaur-9a2639576152d1d7cf45a6ce5c7cea65ba659afe.tar.gz
Initial import
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD49
-rw-r--r--medit.install12
3 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed9daf193ffc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = medit-full
+ pkgdesc = Medit with the python bindings restored
+ pkgver = 1.2.0
+ pkgrel = 2
+ url = http://mooedit.sourceforge.net
+ install = medit.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkg-config
+ makedepends = perl-xml-parser
+ makedepends = intltool
+ makedepends = gcc-objc
+ depends = pygtk
+ depends = libxml2
+ depends = pcre
+ depends = libsm
+ depends = python2
+ depends = gtk2
+ depends = gcc-libs
+ optdepends = ctags
+ optdepends = vte: terminal emulator
+ provides = medit
+ conflicts = medit
+ replaces = medit
+ options = !emptydirs
+ source = http://downloads.sourceforge.net/mooedit/medit-1.2.0.tar.bz2
+ md5sums = 8388a8e275d0e1fa6cd19f7bb081279a
+
+pkgname = medit-full
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df92b658540d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Contributor: Connor Behan <connor.behan@gmail.com>
+
+pkgname=medit-full
+pkgver=1.2.0
+pkgrel=2
+pkgdesc="Medit with the python bindings restored"
+arch=('i686' 'x86_64')
+url="http://mooedit.sourceforge.net"
+options=('!emptydirs')
+license=('GPL')
+depends=('pygtk' 'libxml2' 'pcre' 'libsm' 'python2' 'gtk2' 'gcc-libs')
+optdepends=('ctags' 'vte: terminal emulator')
+makedepends=('pkg-config' 'perl-xml-parser' 'intltool' 'gcc-objc')
+conflicts=('medit')
+replaces=('medit')
+provides=('medit')
+install=medit.install
+source=(http://downloads.sourceforge.net/mooedit/medit-${pkgver}.tar.bz2)
+
+build() {
+ cd "$srcdir"/medit-$pkgver
+ export PYTHON=/usr/bin/python2
+ ./configure --prefix=/usr --with-python --enable-moo-module --enable-shared
+ make
+}
+
+package() {
+ cd "$srcdir"/medit-$pkgver
+ make DESTDIR="$pkgdir" install
+ cd "$pkgdir"/usr/share/medit-1/language-specs
+ sed -i "s|*.sh|*.sh;PKGBUILD|" sh.lang
+ rm -rf "$pkgdir"/usr/share/mime
+ rm -rf "$pkgdir"/usr/share/icons/hicolor/icon-theme.cache
+
+ # Build the stand-alone medit app as well
+ cd "$srcdir"/medit-$pkgver/moo/medit-app
+ gcc -I. -I.. -I../.. `pkg-config --cflags gtk+-2.0` -c main.c
+ mv ../.libs/_moo.so ../.libs/libmoo.so
+ gcc -L../.libs -lmoo `pkg-config --libs gtk+-2.0 gmodule-2.0 gthread-2.0` -o medit main.o
+ install -Dm755 medit "$pkgdir"/usr/bin/medit
+ install -Dm644 medit.desktop.in "$pkgdir"/usr/share/applications/medit.desktop
+ cd ../mooutils/pixmaps
+ install -Dm644 medit.png "$pkgdir"/usr/share/icons/hicolor/48x48/apps/medit.png
+ cd "$pkgdir"/usr/lib
+ ln -s python2.7/site-packages/_moo.so _moo.so
+ # Since we are doing this much work to save a few MB of space, we better delete the static archive
+ rm -f python2.7/site-packages/_moo.a
+}
+md5sums=('8388a8e275d0e1fa6cd19f7bb081279a')
diff --git a/medit.install b/medit.install
new file mode 100644
index 000000000000..b4ee8556fc8e
--- /dev/null
+++ b/medit.install
@@ -0,0 +1,12 @@
+post_install() {
+ which xdg-icon-resource 1>/dev/null 2>/dev/null && xdg-icon-resource forceupdate || true
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ which xdg-icon-resource 1>/dev/null 2>/dev/null && xdg-icon-resource forceupdate || true
+}
+