summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcoreymwamba2015-09-18 10:00:55 +0100
committercoreymwamba2015-09-18 10:00:55 +0100
commit9a27791cb0f0a3841975be5862311fba3eed8e5f (patch)
tree2720cea0573fc697880818b83992078e29585fe6
downloadaur-9a27791cb0f0a3841975be5862311fba3eed8e5f.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--LPC.patch13
-rw-r--r--PKGBUILD40
-rw-r--r--makefile.alsa.patch11
4 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ce274b51603
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = sndpeek-alsa
+ pkgdesc = a real-time audio visualization tool (animated, 3D): ALSA version
+ pkgver = 1.4
+ pkgrel = 1
+ url = http://www.gewang.com/software/sndpeek/
+ arch = i686
+ arch = x86_64
+ groups = multimedia
+ license = GPL
+ depends = libsndfile
+ depends = alsa-lib
+ depends = glu
+ depends = freeglut
+ depends = libxmu
+ provides = sndpeek
+ source = http://soundlab.cs.princeton.edu/software/sndpeek/files/sndpeek-1.4.tgz
+ source = LPC.patch
+ source = makefile.alsa.patch
+ md5sums = 91df9f339230fd6c01f85ebd4cca51cb
+ md5sums = b73a667384ffa9237ded847483c796da
+ md5sums = caa0c3b10406cb0d202e996da618870c
+
+pkgname = sndpeek-alsa
+
diff --git a/LPC.patch b/LPC.patch
new file mode 100644
index 000000000000..fcfa7be9e229
--- /dev/null
+++ b/LPC.patch
@@ -0,0 +1,13 @@
+--- src/marsyas/LPC.cpp 2015-03-01 22:31:15.000000000 +0000
++++ src/marsyas/LPC.new.cpp 2015-09-18 09:38:40.371974107 +0100
+@@ -24,8 +24,8 @@
+ Linear Prediction Coefficients (LPC). Features commonly used
+ in Speech Recognition research.
+ */
+-
+-
++#include <cstdlib>
++#include <math.h>
+ #include "LPC.h"
+
+ LPC::LPC( unsigned int inSize )
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0aaa7a16788
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=sndpeek-alsa
+_pkgname=sndpeek
+pkgver=1.4
+pkgrel=1
+pkgdesc="a real-time audio visualization tool (animated, 3D): ALSA version"
+arch=('i686' 'x86_64')
+url="http://www.gewang.com/software/sndpeek/"
+license=('GPL')
+groups=('multimedia')
+depends=('libsndfile' 'alsa-lib' 'glu' 'freeglut' 'libxmu')
+provides=('sndpeek')
+source=("http://soundlab.cs.princeton.edu/software/sndpeek/files/$_pkgname-$pkgver.tgz" "LPC.patch" "makefile.alsa.patch")
+md5sums=('91df9f339230fd6c01f85ebd4cca51cb'
+ 'b73a667384ffa9237ded847483c796da'
+ 'caa0c3b10406cb0d202e996da618870c')
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver/src/marsyas"
+ patch -p2 -i "$srcdir/LPC.patch"
+ cd "$srcdir/$_pkgname-$pkgver/src/$_pkgname"
+ patch -i "$srcdir/makefile.alsa.patch"
+}
+
+build() {
+ cd "$_pkgname-$pkgver/src/$_pkgname"
+ make linux-alsa
+}
+
+package() {
+ cd "$pkgdir"
+ mkdir -p /usr/bin
+ cd "$srcdir/$_pkgname-$pkgver/src/$_pkgname"
+ install -p -D $_pkgname -m 0755 $pkgdir/usr/bin/$pkgname
+}
diff --git a/makefile.alsa.patch b/makefile.alsa.patch
new file mode 100644
index 000000000000..a7d727f195ae
--- /dev/null
+++ b/makefile.alsa.patch
@@ -0,0 +1,11 @@
+--- makefile.alsa 2015-03-01 22:31:15.000000000 +0000
++++ newmake.alsa 2015-09-18 08:20:37.270520932 +0100
+@@ -4,7 +4,7 @@
+ INCLUDES=-I../marsyas/
+ MARSYAS_DIR=../marsyas/
+ CFLAGS=-D__LINUX_ALSA__ -D__LITTLE_ENDIAN__ $(INCLUDES) -O3 -c
+-LIBS=-L/usr/X11R6/lib -lglut -lGL -lGLU -lasound -lXmu -lX11 -lXext -lXi -lm -lsndfile
++LIBS=-L/usr/X11R6/lib -lglut -lGL -lGLU -lasound -lXmu -lX11 -lXext -lXi -lm -lsndfile -pthread
+
+ OBJS=chuck_fft.o RtAudio.o Thread.o sndpeek.o Stk.o \
+ Centroid.o DownSampler.o Flux.o LPC.o MFCC.o RMS.o Rolloff.o \