summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryustin2023-04-23 09:09:54 +0200
committeryustin2023-04-23 09:09:54 +0200
commit9a452dd42d4ba11e522c1dc3452bd55a51e2837d (patch)
tree8a022d9361735949bee5210c3293a4fda4e31709
parent68ac91160f57a02dcacd53abc71e7d50ca06dfe7 (diff)
downloadaur-9a452dd42d4ba11e522c1dc3452bd55a51e2837d.tar.gz
7.1.89-2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--sndfilexprt.patch8
3 files changed, 18 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ca9b2e7f755..0a89aac337e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = radium
pkgdesc = A graphical music editor. A next generation tracker.
pkgver = 7.1.89
- pkgrel = 1
+ pkgrel = 2
url = https://users.notam02.no/~kjetism/radium
install = radium.install
arch = x86_64
@@ -66,11 +66,13 @@ pkgbase = radium
source = radium.install
source = grep.patch
source = build_linux_common.patch
+ source = sndfilexprt.patch
sha256sums = 5db084512812519218e3101c84f24f0f84fda54af9e92c19a20cb224f08a482c
sha256sums = ed456586a1f28eec9acd081a676e61145e13f07c1a6e967c0af1f7d08be4023e
sha256sums = 2f145e84c5940f4f82544ae68e668d5bd02ee7bce559d3354f60d12eaea1a548
sha256sums = f627730ff7a819e8cc5ac5c2b5f1fb2f2237327db6ea5442c55a23c1ce82ef14
sha256sums = 7ccb4eb8c2924a5b6c610b4f35bc9ff22602cb2e131035d285bef87d813460b3
sha256sums = 0decfc3adcba836004ac34d970a83d4d0b69743334a586f42be53b3de7bdd5a4
+ sha256sums = SKIP
pkgname = radium
diff --git a/PKGBUILD b/PKGBUILD
index 719238a4c434..da2f3c79f19d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=radium
pkgver=7.1.89
-pkgrel=1
+pkgrel=2
pkgdesc='A graphical music editor. A next generation tracker.'
arch=(x86_64)
url=https://users.notam02.no/~kjetism/radium
@@ -76,6 +76,7 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/kmatheussen/radium/archive/
radium.install
grep.patch
build_linux_common.patch
+ sndfilexprt.patch
)
sha256sums=('5db084512812519218e3101c84f24f0f84fda54af9e92c19a20cb224f08a482c'
'ed456586a1f28eec9acd081a676e61145e13f07c1a6e967c0af1f7d08be4023e'
@@ -83,6 +84,7 @@ sha256sums=('5db084512812519218e3101c84f24f0f84fda54af9e92c19a20cb224f08a482c'
'f627730ff7a819e8cc5ac5c2b5f1fb2f2237327db6ea5442c55a23c1ce82ef14'
'7ccb4eb8c2924a5b6c610b4f35bc9ff22602cb2e131035d285bef87d813460b3'
'0decfc3adcba836004ac34d970a83d4d0b69743334a586f42be53b3de7bdd5a4'
+ 'SKIP'
)
install=radium.install
@@ -102,9 +104,13 @@ prepare() {
# !! Comment next line out if you have LMMS installed as it already comes with their own version of Calf plugins !!
for file in bin/sounds/*.rad; do sed -i -e 's/Calf MultiChorus LADSPA/Calf Multi Chorus LADSPA/g' "$file"; done
# See comment on calf-ladspa AUR page then on how to let Radium load Calf from LMMS package
+
+ # temp fix for soundfileexport
+ patch -p0 < "$srcdir/sndfilexprt.patch"
cd bin/packages
patch -p0 < "$srcdir/build_libpds.patch"
+
}
build() {
diff --git a/sndfilexprt.patch b/sndfilexprt.patch
new file mode 100644
index 000000000000..2746b6ed251a
--- /dev/null
+++ b/sndfilexprt.patch
@@ -0,0 +1,8 @@
+--- bin/run_radium_linux.sh.orig 2023-04-23 01:12:04.122074816 +0200
++++ bin/run_radium_linux.sh 2023-04-23 01:12:17.465407822 +0200
+@@ -26,4 +26,4 @@
+ unset QT_QPA_PLATFORM
+ unset QT_PLUGIN_PATH
+
+-QT_QPA_PLATFORM="xcb" LD_LIBRARY_PATH="$LD_LIBRARY_PATH" "$THIS_DIR"/radium_linux.bin "$@"
++LC_ALL=C QT_QPA_PLATFORM="xcb" LD_LIBRARY_PATH="$LD_LIBRARY_PATH" "$THIS_DIR"/radium_linux.bin "$@"