summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-11-09 18:55:03 +0000
committerDaniel Bermond2018-11-09 18:55:03 +0000
commit9a8cdb3d3525a5f927133a4ce1214581018d4bf6 (patch)
treef15ccf8503fb1172c08fe10ad2020b68eb158bd6
parent3690aee63749c1889ce6f440df8d49c066f11d8d (diff)
downloadaur-9a8cdb3d3525a5f927133a4ce1214581018d4bf6.tar.gz
Remove 10bit template
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD61
-rw-r--r--davs2-1.0-disable-10bit.patch23
3 files changed, 9 insertions, 80 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6cd7628da627..b5ed5170dfde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = davs2
pkgdesc = Open-Source encoder of AVS2-P2/IEEE1857.4 video coding standard
pkgver = 1.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/pkuvcl/davs2/
arch = i686
arch = x86_64
@@ -12,15 +12,12 @@ pkgbase = davs2
depends = glibc
depends = liblsmash.so
provides = libdavs2
- provides = libdavs2.so
conflicts = libdavs2
replaces = libdavs2
source = davs2-1.0.tar.gz::https://github.com/pkuvcl/davs2/archive/1.0.tar.gz
source = davs2-1.0-add-linux-support.patch
- source = davs2-1.0-disable-10bit.patch
sha256sums = 1b8bd800f7c4d63e904a4355de0144c55d427d3f1477064b53de1c3e028d9eaa
sha256sums = 66166908defadbac7bbaab44a2eaab09af9f6b9ad37c035772e32a6a09c0b605
- sha256sums = d9ff66752e6a30cbd94526f77074bfe826628cf3a285b19443cc53a803316c2f
pkgname = davs2
diff --git a/PKGBUILD b/PKGBUILD
index cd9b74a0fa80..1a03be1321a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,22 +6,20 @@
pkgname=davs2
pkgver=1.0
-pkgrel=3
+pkgrel=4
arch=('i686' 'x86_64')
pkgdesc='Open-Source encoder of AVS2-P2/IEEE1857.4 video coding standard'
url='https://github.com/pkuvcl/davs2/'
license=('GPL')
depends=('glibc' 'liblsmash.so')
makedepends=('gcc7' 'yasm' 'l-smash')
-provides=('libdavs2' 'libdavs2.so')
+provides=('libdavs2')
conflicts=('libdavs2')
replaces=('libdavs2')
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/pkuvcl/${pkgname}/archive/${pkgver}.tar.gz"
- 'davs2-1.0-add-linux-support.patch'
- 'davs2-1.0-disable-10bit.patch')
+ 'davs2-1.0-add-linux-support.patch')
sha256sums=('1b8bd800f7c4d63e904a4355de0144c55d427d3f1477064b53de1c3e028d9eaa'
- '66166908defadbac7bbaab44a2eaab09af9f6b9ad37c035772e32a6a09c0b605'
- 'd9ff66752e6a30cbd94526f77074bfe826628cf3a285b19443cc53a803316c2f')
+ '66166908defadbac7bbaab44a2eaab09af9f6b9ad37c035772e32a6a09c0b605')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -30,21 +28,17 @@ prepare() {
sed -i $'s/\r$//' source/common/vec/intrinsic_sao_avx2.cc
patch -Np1 -i "${srcdir}/davs2-1.0-add-linux-support.patch"
- # disable 10-bit in configure to avoid misleading errors
- patch -Np1 -i "${srcdir}/davs2-1.0-disable-10bit.patch"
-
# use gcc7 (it does not build with gcc8)
sed -i 's/g++/g++-7/' build/linux/configure
- # must copy the entire source tree for each build or it will not work
+ # must copy the entire source tree or it will not work
cd "$srcdir"
cp -af "${pkgname}-${pkgver}" build-8bit
- cp -af "${pkgname}-${pkgver}" build-10bit
}
build() {
- printf '%s\n' ' -> Building for 8-bit...'
cd build-8bit/build/linux
+
./configure \
--prefix='/usr' \
--enable-shared \
@@ -56,49 +50,10 @@ build() {
--disable-lavf \
--disable-ffms \
--disable-gpac
+
make
-
- printf '%s\n' ' -> Building for 10-bit...'
- cd "${srcdir}/build-10bit/build/linux"
- if ./configure \
- --prefix='/usr' \
- --libdir='/usr/lib/davs2-10bit' \
- --includedir='/usr/include/davs2-10bit' \
- --enable-shared \
- --bit-depth='10' \
- --chroma-format='all' \
- --enable-lto \
- --enable-pic \
- --disable-swscale \
- --disable-lavf \
- --disable-ffms \
- --disable-gpac
- then
- make
- else
- cd "$srcdir"
- rm -rf build-10bit
- fi
}
package() {
- local _depth
-
- for _depth in 10 8
- do
- printf '%s\n' " -> Installing for ${_depth}-bit..."
-
- if [ "$_depth" -eq '10' ] && ! [ -d 'build-10bit' ]
- then
- printf '%s\n' 'BitDepth 10 not supported currently.'
- continue
- fi
-
- make -C "build-${_depth}bit/build/linux" DESTDIR="$pkgdir" install-cli install-lib-shared
-
- if [ "$_depth" -eq '10' ]
- then
- mv "${pkgdir}/usr/bin/davs2" "${pkgdir}/usr/bin/davs2-${_depth}bit"
- fi
- done
+ make -C build-8bit/build/linux DESTDIR="$pkgdir" install-cli install-lib-shared
}
diff --git a/davs2-1.0-disable-10bit.patch b/davs2-1.0-disable-10bit.patch
deleted file mode 100644
index 55b1dd453ed9..000000000000
--- a/davs2-1.0-disable-10bit.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 2b5b6fb8b8c7ea35d482ea7fc17e5fcb05cc4708 Mon Sep 17 00:00:00 2001
-From: luofl <falei.luo@gmail.com>
-Date: Sat, 28 Jul 2018 18:52:35 +0800
-Subject: [PATCH] Disable `10-bit` in configure to avoid misleading errors.
-
----
- build/linux/configure | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/build/linux/configure b/build/linux/configure
-index bcbf22d..a3d26eb 100755
---- a/build/linux/configure
-+++ b/build/linux/configure
-@@ -499,6 +499,9 @@ for opt do
- if [ "$bit_depth" -lt "8" -o "$bit_depth" -gt "10" ]; then
- echo "Supplied bit depth must be in range [8,10]."
- exit 1
-+ elif [[ "$bit_depth" = "9" || "$bit_depth" = "10" ]]; then
-+ echo "BitDepth $bit_depth not supported currently."
-+ exit 1
- fi
- bit_depth=`expr $bit_depth + 0`
- ;;