summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2023-04-20 15:39:33 +0800
committertaotieren2023-04-20 15:39:33 +0800
commit9aad3de3728086a3015ff587d719c113b210db29 (patch)
tree2d71189d5e61ab7571cd07cc9e5777f1bac90caa
parentcca3efd138977cb915de067860f18411ef50d8db (diff)
downloadaur-9aad3de3728086a3015ff587d719c113b210db29.tar.gz
update 3.0.06-0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e34126793bf2..7641ca898755 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = at-link-console-bin
pkgdesc = Artery AT LINK Console 是一款基于 MCU Bootloader 的命令行应用程序。支持AT32 MCU「在电路编程」Console工具
- pkgver = 3.0.04
+ pkgver = 3.0.06
pkgrel = 0
url = https://www.arterytek.com/cn/product/AT32F403.jsp
install = at-link-console-bin.install
arch = x86_64
license = Commercial
- makedepends = unarchiver
+ makedepends = unzip
depends = icu
depends = qt5-base
depends = gcc-libs
@@ -23,9 +23,9 @@ pkgbase = at-link-console-bin
depends = libgcrypt
depends = libgpg-error
provides = AT-LINK_Console
- noextract = Artery_ATLINK_Console_V3.0.04.zip
+ noextract = Artery_ATLINK_Console_V3.0.06.zip
options = !strip
- source = Artery_ATLINK_Console_V3.0.04.zip::https://www.arterytek.com/download/TOOL/Artery_ATLINK_Console_Linux-x86_64_V3.0.04.zip
- sha256sums = f5b9862f6286eb7ae6c000dbd4e8cdf102b096e6106d3bef5fd72632b1bae10f
+ source = Artery_ATLINK_Console_V3.0.06.zip::https://www.arterytek.com/download/TOOL/Artery_ATLINK_Console_Linux-x86_64_V3.0.06.zip
+ sha256sums = 6453d5f52ad1c03e97c40fe3b608e327ffdd81b81dccad3150f9ad99fba0beee
pkgname = at-link-console-bin
diff --git a/PKGBUILD b/PKGBUILD
index 52fdfd5dc8a7..beefeebd232e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: taotieren <admin@taotieren.com>
pkgname=at-link-console-bin
-pkgver=3.0.04
+pkgver=3.0.06
pkgrel=0
pkgdesc="Artery AT LINK Console 是一款基于 MCU Bootloader 的命令行应用程序。支持AT32 MCU「在电路编程」Console工具"
arch=('x86_64')
@@ -11,21 +11,19 @@ provides=(AT-LINK_Console)
conflicts=()
replaces=()
depends=('icu' 'qt5-base' 'gcc-libs' 'glibc' 'systemd-libs' 'zlib' 'double-conversion' 'pcre2' 'zstd' 'glib2' 'xz' 'lz4' 'libcap' 'libgcrypt' 'libgpg-error')
-makedepends=('unarchiver')
+makedepends=('unzip')
backup=()
options=('!strip')
install=${pkgname}.install
_pkg_file_name=Artery_ATLINK_Console_V${pkgver}.zip
source=("${_pkg_file_name}::https://www.arterytek.com/download/TOOL/Artery_ATLINK_Console_Linux-${arch}_V${pkgver}.zip")
-sha256sums=('f5b9862f6286eb7ae6c000dbd4e8cdf102b096e6106d3bef5fd72632b1bae10f')
+sha256sums=('6453d5f52ad1c03e97c40fe3b608e327ffdd81b81dccad3150f9ad99fba0beee')
noextract=(${_pkg_file_name})
-build() {
- unar -e GBK ${srcdir}/${_pkg_file_name}
-}
-
package() {
- cd "${srcdir}/${_pkg_file_name%.zip}/"
+ unzip -O gbk -o "${srcdir}"/${_pkg_file_name} -d "${srcdir}"
+
+ cd "${srcdir}"
install -dm0755 "${pkgdir}/opt/artery32/${pkgname%-bin}/" \
"${pkgdir}/usr/lib/"