summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2020-01-21 18:58:00 +0200
committerChristoph Fink2020-01-21 18:58:00 +0200
commit9ac20d66863867b9d5df54d02e92676df4dc1d51 (patch)
treed95075733071681c2357eb72312398ec2ea56c60
parentc2b5c65225d5a814d97ab321a11fc08ab76b9758 (diff)
downloadaur-9ac20d66863867b9d5df54d02e92676df4dc1d51.tar.gz
dropping python2 support
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD30
2 files changed, 11 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36693c80d029..59a50e7acf07 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,15 @@
pkgbase = python-webhoseio
pkgdesc = Simple client library for the webhose.io REST API
pkgver = 0.5
- pkgrel = 0
+ pkgrel = 1
url = https://github.com/Webhose/webhoseio-python/
arch = any
license = MIT
makedepends = python-setuptools
- makedepends = python2-setuptools
+ depends = python
+ depends = python-requests
source = https://files.pythonhosted.org/packages/source/w/webhoseio/webhoseio-0.5.tar.gz
sha256sums = a5ec55b84e46dc02b4f332bbdef84e80c0585042ea22bc8eb5ae6f803773aefe
pkgname = python-webhoseio
- depends = python
- depends = python-requests
-
-pkgname = python2-webhoseio
- depends = python2
- depends = python2-requests
diff --git a/PKGBUILD b/PKGBUILD
index f2688d1a037d..95d180c7eaac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,19 @@
# Maintainer: peippo <christoph.fink@gmail.com>
-pkgbase=python-webhoseio
-pkgname=('python-webhoseio' 'python2-webhoseio')
+pkgname=python-webhoseio
pkgver=0.5
-pkgrel=0
+pkgrel=1
pkgdesc="Simple client library for the webhose.io REST API"
url="https://github.com/Webhose/webhoseio-python/"
license=('MIT')
arch=('any')
-makedepends=('python-setuptools' 'python2-setuptools')
+makedepends=('python-setuptools')
+depends=(
+ 'python'
+ 'python-requests'
+)
_name=${pkgname#python-}
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
@@ -18,37 +21,20 @@ sha256sums=('a5ec55b84e46dc02b4f332bbdef84e80c0585042ea22bc8eb5ae6f803773aefe')
prepare() {
rm -rf ${_name}-$pkgver/*.egg-info
- cp -a ${_name}-$pkgver{,-py2}
}
build() {
cd "$srcdir"/${_name}-$pkgver
python setup.py build
-
- cd "$srcdir"/${_name}-$pkgver-py2
- python2 setup.py build
}
check() {
cd "$srcdir"/${_name}-$pkgver
python setup.py test
-
- cd "$srcdir"/${_name}-$pkgver-py2
- python2 setup.py test
}
-package_python-webhoseio() {
- depends=('python' 'python-requests')
-
+package() {
cd ${_name}-$pkgver
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.rst
}
-
-package_python2-webhoseio() {
- depends=('python2' 'python2-requests')
-
- cd ${_name}-$pkgver-py2
- python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.rst
-}