summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Veness2021-03-22 14:58:39 -0700
committerTyler Veness2021-03-22 14:58:39 -0700
commit9ad132a9f558358254941c5980e55e76aa5ce967 (patch)
tree43f5baeb87f55fa160efb4005fae343ec755ff76
parentf7753cb2f8b389c3fdcaeee997f0437b3b9d81bc (diff)
downloadaur-9ad132a9f558358254941c5980e55e76aa5ce967.tar.gz
Update to SLICOT-Reference
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
2 files changed, 18 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 233bbd9a3c3b..569f8a8afa23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-slycot-git
pkgdesc = Python wrapper for selected SLICOT routines, notably including solvers for Riccati, Lyapunov and Sylvester equations.
- pkgver = 292.2f31897
+ pkgver = 517.a40505a
pkgrel = 1
url = http://github.com/python-control/Slycot
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 61e4aa6a154e..886c219ff861 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: James Duley <jagduley gmail>
pkgname=python-slycot-git
-pkgver=292.2f31897
+pkgver=517.a40505a
pkgrel=1
pkgdesc="Python wrapper for selected SLICOT routines, notably including solvers for Riccati, Lyapunov and Sylvester equations."
arch=('i686' 'x86_64')
@@ -21,16 +21,30 @@ pkgver() {
echo $(git rev-list --count master).$(git rev-parse --short master)
}
+prepare() {
+ cd "$srcdir/Slycot"
+ git submodule update --init
+}
+
build() {
cd "$srcdir/Slycot"
- python setup.py build
+ # Link against the Generic NetLIB blas/lapack ABI. If openblas is installed
+ # instead of blas, that one will provide the library. Same mechanism as in
+ # Extra/python-numpy
+ export BLA_VENDOR=Generic
+ python setup.py build -G "Unix Makefiles"
+}
+
+check() {
+ cd "$srcdir/Slycot"
+ pytest
}
package() {
export LDFLAGS="$LDFLAGS -shared"
cd "$srcdir/Slycot"
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+ python setup.py install -G "Unix Makefiles" --prefix=/usr --root="${pkgdir}" --optimize=1
}
# vim:set ts=2 sw=2 et: