summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrenton Horne2020-02-11 17:31:55 +1000
committerBrenton Horne2020-02-11 17:31:55 +1000
commit9adafab6e8bef7986aab6253a981eb6e8f9f994d (patch)
tree0f02ebbbc766ed0a8db327d79b76c24717340bb6
downloadaur-9adafab6e8bef7986aab6253a981eb6e8f9f994d.tar.gz
Initial commit
-rw-r--r--.SRCINFO37
-rw-r--r--.gitignore5
-rwxr-xr-xPKGBUILD67
-rwxr-xr-xopenra-radot519
-rwxr-xr-xopenra-radot5.appdata.xml36
-rwxr-xr-xopenra-radot5.desktop11
-rwxr-xr-xopenra-radot5.install14
7 files changed, 189 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e323cbd64921
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = openra-radot5-git
+ pkgdesc = OpenRA mod that tell the storyline between 1936 to Red Alert 1
+ pkgver = 157.git.5f7c0d2
+ pkgrel = 1
+ url = https://github.com/MustaphaTR/Red-Alert-.5
+ install = openra-radot5.install
+ arch = any
+ license = GPL3
+ makedepends = dos2unix
+ makedepends = git
+ makedepends = unzip
+ makedepends = msbuild
+ depends = mono
+ depends = ttf-dejavu
+ depends = openal
+ depends = libgl
+ depends = freetype2
+ depends = sdl2
+ depends = lua51
+ depends = hicolor-icon-theme
+ depends = gtk-update-icon-cache
+ depends = desktop-file-utils
+ depends = xdg-utils
+ depends = zenity
+ provides = openra-radot5
+ options = !strip
+ source = git+https://github.com/MustaphaTR/Red-Alert-.5.git
+ source = openra-radot5
+ source = openra-radot5.appdata.xml
+ source = openra-radot5.desktop
+ md5sums = SKIP
+ md5sums = 19f94aacaab367f2dada6c5d89987a8f
+ md5sums = c53603fdbe9b438722658226bcc36aee
+ md5sums = aa5929872e801213be21a5d4f0b58f3b
+
+pkgname = openra-radot5-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..70b409008fe1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.xz
+Red-Alert-.5
+pkg
+src
+*.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..f5c92ae0efc5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Brenton Horne <brentonhorne77@gmail.com>
+
+pkgname=openra-radot5-git
+_pkgname=openra-radot5
+pkgver=157.git.5f7c0d2
+pkgrel=1
+pkgdesc="OpenRA mod that tell the storyline between 1936 to Red Alert 1"
+arch=('any')
+url="https://github.com/MustaphaTR/Red-Alert-.5"
+license=('GPL3')
+install=openra-radot5.install
+depends=('mono' 'ttf-dejavu' 'openal' 'libgl' 'freetype2' 'sdl2' 'lua51' 'hicolor-icon-theme' 'gtk-update-icon-cache'
+ 'desktop-file-utils' 'xdg-utils' 'zenity')
+makedepends=('dos2unix' 'git' 'unzip' 'msbuild')
+provides=('openra-radot5')
+options=(!strip)
+source=("git+${url}.git"
+"openra-radot5"
+"openra-radot5.appdata.xml"
+"openra-radot5.desktop")
+md5sums=('SKIP'
+ '19f94aacaab367f2dada6c5d89987a8f'
+ 'c53603fdbe9b438722658226bcc36aee'
+ 'aa5929872e801213be21a5d4f0b58f3b')
+
+pkgver() {
+ cd $srcdir/Red-Alert-.5
+ no=$(git rev-list --count HEAD)
+ hash=$(git log | head -n 1 | cut -d ' ' -f 2 | head -c 7)
+ printf "${no}.git.${hash}"
+}
+
+prepare() {
+ cd $srcdir/Red-Alert-.5
+ dos2unix *.md
+ printf "Success in converting docs...\n"
+}
+
+build() {
+ cd $srcdir/Red-Alert-.5
+ make version VERSION="${pkgver}"
+ printf "Success in setting version\n"
+ make || (printf "make failed; please do not complain at the AUR about this, as this is an upstream issue.\n" && \
+ printf "So report this at https://github.com/MustaphaTR/Red-Alert-.5/issues/new, after checking\n" && \
+ printf "for existing issues.\n")
+}
+
+package() {
+ cd $srcdir/Red-Alert-.5
+ mkdir -p $pkgdir/usr/{lib/openra-radot5/mods,bin,share/pixmaps,share/doc/packages/openra-radot5,share/applications,share/appdata}
+ install -dm775 $pkgdir/var/games/openra-radot5
+ cp -r engine/* $pkgdir/usr/lib/openra-radot5
+ cp -r mods/radot5 $pkgdir/usr/lib/openra-radot5/mods
+ cp -r engine/mods/{as,common,modcontent} $pkgdir/usr/lib/openra-radot5/mods
+ install -Dm755 $srcdir/openra-radot5 $pkgdir/usr/bin/openra-radot5
+ cp -r $srcdir/openra-radot5.appdata.xml $pkgdir/usr/share/appdata/openra-radot5.appdata.xml
+ cp -r README.md $pkgdir/usr/share/doc/packages/openra-radot5/README.md
+ cp -r mods/radot5/icon.png $pkgdir/usr/share/pixmaps/openra-radot5.png
+ install -Dm644 $srcdir/openra-radot5.desktop $pkgdir/usr/share/applications/openra-radot5.desktop
+ mkdir -p $pkgdir/usr/share/icons/hicolor/{16x16,32x32,48x48,64x64,128x128,256x256}/apps
+ for size in 16 32 48 64 128 256; do
+ size="${size}x${size}"
+ cp packaging/linux/mod_${size}.png "$pkgdir/usr/share/icons/hicolor/${size}/apps/${pkgname}.png"
+ done
+ rm -rf $pkgdir/usr/lib/openra-radot5/*{.txt,nunit,.yml,.xslt,.cmd,.md,Mono,.sh,Makefile,sln.*,Test,.mdb,.pdb,.ps1,.AS,packaging,thirdparty,engines,OpenRA.Mods}*
+ rm -rf $pkgdir/usr/lib/openra-radot5/{mods/{all,cnc,d2k,ra,ts},OpenRA.Mods.*,OpenRA.Platforms.Default,OpenRA.Server,OpenRA.Game,OpenRA.Utility,Settings.StyleCop}
+}
diff --git a/openra-radot5 b/openra-radot5
new file mode 100755
index 000000000000..1825d9daaea5
--- /dev/null
+++ b/openra-radot5
@@ -0,0 +1,19 @@
+#!/bin/sh
+cd "/usr/lib/openra-radot5"
+
+# Run the game
+mono --debug OpenRA.Game.exe Game.Mod=radot5 Engine.LaunchPath="/usr/bin/openra-radot5" "Engine.ModSearchPaths=/usr/lib/openra-radot5/mods" "$@"
+
+# Show a crash dialog if something went wrong
+if [ $? != 0 ] && [ $? != 1 ]; then
+ ERROR_MESSAGE="OpenRA Red Alert .5 has encountered a fatal error.\nPlease refer to the crash logs and FAQ for more information.\n\nLog files are located in ~/.openra/Logs\nThe FAQ is available at http://wiki.openra.net/FAQ"
+ if command -v zenity > /dev/null; then
+ zenity --no-wrap --error --title "OpenRA Red Alert .5" --text "${ERROR_MESSAGE}" 2> /dev/null
+ elif command -v kdialog > /dev/null; then
+ kdialog --title "OpenRA Red Alert .5" --error "${ERROR_MESSAGE}"
+ else
+ printf "${ERROR_MESSAGE}\n"
+ fi
+ exit 1
+fi
+
diff --git a/openra-radot5.appdata.xml b/openra-radot5.appdata.xml
new file mode 100755
index 000000000000..8a0aa3a7c06d
--- /dev/null
+++ b/openra-radot5.appdata.xml
@@ -0,0 +1,36 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<component type="desktop">
+ <id>openra-radot5.desktop</id>
+ <metadata_license>CC0-1.0</metadata_license>
+ <project_license>GPL-3.0</project_license>
+ <name>OpenRA - Red Alert .5</name>
+ <summary>OpenRA mod that tell the storyline between 1936 to Red Alert 1.</summary>
+ <description>
+ <p>
+ OpenRA Red Alert .5 is a project that attempts to tell the storyline between 1936 to Red Alert 1.
+ </p>
+ </description>
+ <url type="homepage">https://github.com/MustaphaTR/Red-Alert-.5</url>
+ <content_rating type="oars-1.0">
+ <content_attribute id="violence-cartoon">none</content_attribute>
+ <content_attribute id="violence-fantasy">none</content_attribute>
+ <content_attribute id="violence-realistic">moderate</content_attribute>
+ <content_attribute id="violence-bloodshed">moderate</content_attribute>
+ <content_attribute id="violence-sexual">none</content_attribute>
+ <content_attribute id="drugs-alcohol">none</content_attribute>
+ <content_attribute id="drugs-narcotics">none</content_attribute>
+ <content_attribute id="drugs-tobacco">none</content_attribute>
+ <content_attribute id="sex-nudity">none</content_attribute>
+ <content_attribute id="sex-themes">none</content_attribute>
+ <content_attribute id="language-profanity">mild</content_attribute>
+ <content_attribute id="language-humor">mild</content_attribute>
+ <content_attribute id="language-discrimination">none</content_attribute>
+ <content_attribute id="social-chat">intense</content_attribute>
+ <content_attribute id="social-info">none</content_attribute>
+ <content_attribute id="social-audio">none</content_attribute>
+ <content_attribute id="social-location">none</content_attribute>
+ <content_attribute id="social-contacts">none</content_attribute>
+ <content_attribute id="money-purchasing">none</content_attribute>
+ <content_attribute id="money-gambling">none</content_attribute>
+ </content_rating>
+</component>
diff --git a/openra-radot5.desktop b/openra-radot5.desktop
new file mode 100755
index 000000000000..26c503c5a6b6
--- /dev/null
+++ b/openra-radot5.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=OpenRA - Red Alert .5
+GenericName=Real Time Strategy Game
+GenericName[de]=Echtzeit-Strategiespiel
+Comment=Reimagining of the Red Alert 2 game
+Icon=openra-radot5
+Exec=openra-radot5
+Terminal=false
+Categories=Game;StrategyGame;X-RTS;X-RealTimeStrategy;X-RealTimeStrategyGame;
diff --git a/openra-radot5.install b/openra-radot5.install
new file mode 100755
index 000000000000..1028d2b6a1eb
--- /dev/null
+++ b/openra-radot5.install
@@ -0,0 +1,14 @@
+post_upgrade() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_install() {
+ echo "You will need the original game assets to play this game, see https://github.com/OpenRA/ra2/wiki for details."
+ echo "Beware you will need the expansion game assets, which are only in C&C: Ultimate Edition."
+ post_upgrade
+}
+
+post_remove() {
+ post_upgrade
+}