summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThiago L. A. Miller2019-03-21 23:25:56 -0300
committerThiago L. A. Miller2019-03-21 23:25:56 -0300
commit9af5606e8763a7b81255a1db85301b57b20d0fb3 (patch)
tree3373eacbf0333ebf571277fc2c29a932bd508c18
parentd3bbda34c1685c3bd64de7fbbf5644b64748c076 (diff)
downloadaur-9af5606e8763a7b81255a1db85301b57b20d0fb3.tar.gz
FIx building with Module::Install
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD48
3 files changed, 33 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9b16f8636f3..0e925fb0e985 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
-# Generated by mksrcinfo v8
-# Wed Aug 8 13:33:47 UTC 2018
pkgbase = perl-test-use-ok
pkgdesc = Alternative to Test::More::use_ok
pkgver = 0.11
- pkgrel = 3
- url = http://search.cpan.org/~audreyt/Test-use-ok
+ pkgrel = 4
+ url = http://search.mcpan.org/dist/Test-use-ok
arch = any
license = GPL
license = PerlArtistic
depends = perl>=5.8.9
options = !emptydirs
source = http://search.cpan.org/CPAN/authors/id/A/AU/AUDREYT/Test-use-ok-0.11.tar.gz
- sha256sums = 8410438a2acf127bffcf1ab92205b747a615b487e80a48e8c3d0bb9fa0dbb2a8
+ md5sums = 014364cc2f0df651d8416ebb60451f18
pkgname = perl-test-use-ok
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e20245338b32
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
index cebf854a1f93..9664d6b43f8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,47 @@
+# Maintainer: Thiago L. A. Miller <thiago_leisrael@hotmail.com>
+# Contributor: sL1pKn07 <sl1pkn07@gmail.com>
+_distname=Test-use-ok
pkgname=perl-test-use-ok
-_realname=Test-use-ok
pkgver=0.11
-pkgrel=3
+pkgrel=4
pkgdesc="Alternative to Test::More::use_ok"
arch=('any')
+url="http://search.mcpan.org/dist/$_distname"
license=('GPL' 'PerlArtistic')
-url='http://search.cpan.org/~audreyt/Test-use-ok'
-options=(!emptydirs)
depends=('perl>=5.8.9')
-source=('http://search.cpan.org/CPAN/authors/id/A/AU/AUDREYT/Test-use-ok-0.11.tar.gz')
-sha256sums=('8410438a2acf127bffcf1ab92205b747a615b487e80a48e8c3d0bb9fa0dbb2a8')
+makedepends=('')
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/A/AU/AUDREYT/$_distname-$pkgver.tar.gz")
+md5sums=('014364cc2f0df651d8416ebb60451f18')
build() {
- cd "${_realname}-${pkgver}"
- # install module in vendor directories.
- ( export PERL_MM_USE_DEFAULT=1 \
- PERL5LIB="${srcdir}/${_realname}-${pkgver}" \
- PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='${pkgdir}'" \
- PERL_MB_OPT="--installdirs vendor --destdir '${pkgdir}'" \
- MODULEBUILDRC=/dev/null
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
- /usr/bin/perl Makefile.PL
+ cd "$_distname-$pkgver"
+ /usr/bin/perl -I. Makefile.PL
make
)
}
check() {
- cd "${_realname}-${pkgver}"
- ( export PERL_MM_USE_DEFAULT=1 \
- PERL5LIB="${srcdir}/${_realname}-${pkgver}"
-
+ cd "$_distname-$pkgver"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
make test
)
}
package() {
- cd "${_realname}-${pkgver}"
+ cd "$_distname-$pkgver"
make install
-
- find "${pkgdir}" -name '.packlist' -o -name 'perllocal.pod' -delete
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: