summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2016-12-14 12:50:49 -1000
committerGaetan Bisson2016-12-14 12:50:49 -1000
commit9afc976c3560e33345aea38d7c3cfd708e40c5ee (patch)
tree6cb0966abcc3421f9022e2ae13068123bf481925
parentb24780ea3deaca0658200c8d16086e68d215a700 (diff)
downloadaur-9afc976c3560e33345aea38d7c3cfd708e40c5ee.tar.gz
upstream update
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 500983de847f..d7b93a872cbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = stirfs
pkgdesc = Secure, transparent and irresistible filesystem
- pkgver = 1.5
+ pkgver = 1.6
pkgrel = 1
url = http://fenua.org/gaetan/src/
- arch = i686
arch = x86_64
- arch = armv7h
license = ISC
- depends = fuse
+ depends = fuse3
depends = openssl
- source = http://fenua.org/gaetan/src//stirfs-1.5.c
- sha1sums = e832af2179f9224b5572c0b92767733d10f60a2b
+ source = http://fenua.org/gaetan/src//stirfs-1.6.c
+ sha1sums = 731f3569e81c8ff5a53bbd7ca803499e009ea212
pkgname = stirfs
diff --git a/PKGBUILD b/PKGBUILD
index eb0044a46973..882aa651c7b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Gaetan Bisson <bisson@archlinux.org>
pkgname=stirfs
-pkgver=1.5
+pkgver=1.6
pkgrel=1
pkgdesc='Secure, transparent and irresistible filesystem'
url='http://fenua.org/gaetan/src/'
license=('ISC')
-depends=('fuse' 'openssl')
-arch=('i686' 'x86_64' 'armv7h')
+depends=('fuse3' 'openssl')
+arch=('x86_64')
source=("${url}/${pkgname}-${pkgver}.c")
-sha1sums=('e832af2179f9224b5572c0b92767733d10f60a2b')
+sha1sums=('731f3569e81c8ff5a53bbd7ca803499e009ea212')
build() {
cd "${srcdir}"
- cc -lfuse -lcrypto \
+ cc \
+ -I/usr/include/fuse3 -lfuse3 -lcrypto \
${CFLAGS} ${LDFLAGS} \
-o ${pkgname} ${pkgname}-${pkgver}.c
}