summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2013-08-23 16:58:29 +0400
committerAnton Leontiev2015-02-15 07:48:01 +0300
commit9b0db61f58c1eab840e81dee577f1afdabce24b2 (patch)
treeefd8315eeacc37b1da5bc78cf5d8c78bbd1c5d99
downloadaur-9b0db61f58c1eab840e81dee577f1afdabce24b2.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD37
-rw-r--r--xyscan-3.3.1-docs.patch31
-rw-r--r--xyscan.desktop10
-rw-r--r--xyscan.install12
6 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..141038960c24
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = xyscan
+ pkgdesc = Tool to extract data points from graphical plots
+ pkgver = 3.3.1
+ pkgrel = 2
+ url = http://star.physics.yale.edu/~ullrich/xyscanDistributionPage/
+ install = xyscan.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt4>=4.6.0
+ source = http://star.physics.yale.edu/~ullrich/xyscanDistributionPage/3.31/xyscan-3.31-src.tar.gz
+ source = xyscan-3.3.1-docs.patch
+ source = xyscan.desktop
+ md5sums = af25ded942dbfdc4e73c5f9986db6e2e
+ md5sums = 22093f1c22b73f95de1cbfee14d74dc4
+ md5sums = 2df01c952f8425d05e0d138778ca5be9
+
+pkgname = xyscan
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6142ffc6b9f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+pkgname=xyscan
+pkgver=3.3.1
+pkgrel=2
+arch=("i686" "x86_64")
+pkgdesc="Tool to extract data points from graphical plots"
+url="http://star.physics.yale.edu/~ullrich/xyscanDistributionPage/"
+license=("GPL")
+depends=("qt4>=4.6.0")
+source=(http://star.physics.yale.edu/~ullrich/xyscanDistributionPage/3.31/$pkgname-3.31-src.tar.gz
+ xyscan-$pkgver-docs.patch
+ xyscan.desktop)
+md5sums=("af25ded942dbfdc4e73c5f9986db6e2e"
+ "22093f1c22b73f95de1cbfee14d74dc4"
+ "2df01c952f8425d05e0d138778ca5be9")
+install=xyscan.install
+
+build() {
+ cd "$srcdir/$pkgname"
+ patch -i "$srcdir/$pkgname-$pkgver-docs.patch"
+ qmake -o Makefile xyscan.pro
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install --mode=755 -D xyscan $pkgdir/usr/bin/xyscan
+ install --mode=755 --directory $pkgdir/usr/share/doc/xyscan/{en,fr}
+ install --mode=644 --target-directory=$pkgdir/usr/share/doc/xyscan/en docs/en/*
+ install --mode=644 --target-directory=$pkgdir/usr/share/doc/xyscan/fr docs/fr/*
+ install --mode=644 -D images/xyscanIcon.png $pkgdir/usr/share/icons/hicolor/32x32/apps/xyscan.png
+ if test -x /usr/bin/desktop-file-install; then
+ /usr/bin/desktop-file-install --dir $pkgdir/usr/share/applications $srcdir/xyscan.desktop
+ else
+ install --mode=644 -D $srcdir/xyscan.desktop $pkgdir/usr/share/applications/xyscan.desktop
+ fi
+}
diff --git a/xyscan-3.3.1-docs.patch b/xyscan-3.3.1-docs.patch
new file mode 100644
index 000000000000..de105a14b775
--- /dev/null
+++ b/xyscan-3.3.1-docs.patch
@@ -0,0 +1,31 @@
+--- xyscanWindow.cpp.orig 2011-05-16 03:22:20.000000000 +0000
++++ xyscanWindow.cpp 2011-06-28 10:51:46.034524709 +0000
+@@ -396,27 +396,9 @@
+ {
+ mHelpBrowser = 0;
+
+- QString path = qApp->applicationDirPath() + "/docs";
++ QString path = "/usr/share/doc/xyscan";
+ QDir dir(path);
+ if (!dir.exists()) {
+- path = qApp->applicationDirPath() + "/../docs";
+- dir.setPath(path);
+- }
+-#if defined(Q_OS_MAC)
+- if (!dir.exists()) {
+- path = qApp->applicationDirPath() + "/../Resources/docs";
+- dir.setPath(path);
+- }
+-#endif
+- //
+- // For developing on Mac/Xcode only: avoids having to copy
+- // the docs into the build substructure.
+- //
+- if (!dir.exists()) {
+- path = "/Users/ullrich/Documents/Projects/xyscan/docs";
+- dir.setPath(path);
+- }
+- if (!dir.exists()) {
+ QMessageBox::warning( 0, "xyscan",
+ tr("Cannot find the directory holding the documentation (docs). "
+ "No online help will be available. "
diff --git a/xyscan.desktop b/xyscan.desktop
new file mode 100644
index 000000000000..39e83a295f70
--- /dev/null
+++ b/xyscan.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Xyscan
+Categories=Education;Science;Graphics;2DGraphics;
+Comment=Tool to extract data points from graphical plots
+Comment[ru]=Программа для определения координат точек по растровому графику
+TryExec=xyscan
+Exec=xyscan
+Icon=xyscan
diff --git a/xyscan.install b/xyscan.install
new file mode 100644
index 000000000000..6cf972aacc63
--- /dev/null
+++ b/xyscan.install
@@ -0,0 +1,12 @@
+post_install() {
+ [ -x /usr/bin/gtk-update-icon-cache ] && gtk-update-icon-cache -q -f -t usr/share/icons/hicolor
+ [ -x /usr/bin/update-desktop-database ] && /usr/bin/update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}