summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-12-25 23:03:30 +0100
committersl1pkn072015-12-25 23:03:30 +0100
commit9b1c03e3b711976634aeec56f24b176aff2edd8c (patch)
treea04cdba609840cdadec21ddd623e93ed0154595e
parent1aaea60dadcbd3e6375e9e82f6474ac6a1cb735d (diff)
downloadaur-9b1c03e3b711976634aeec56f24b176aff2edd8c.tar.gz
update PKGBUILD
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0eb6f5ff766b..80af90899dce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Fri Dec 25 22:02:47 UTC 2015
pkgbase = vapoursynth-plugin-scxvid-git
pkgdesc = Plugin for Vapoursynth: scxvid (GIT version)
pkgver = v1.0.ge9deca0
@@ -11,7 +13,7 @@ pkgbase = vapoursynth-plugin-scxvid-git
provides = vapoursynth-plugin-scxvid
conflicts = vapoursynth-plugin-scxvid
source = scxvid::git+https://github.com/dubhater/vapoursynth-scxvid.git
- md5sums = SKIP
+ sha1sums = SKIP
pkgname = vapoursynth-plugin-scxvid-git
diff --git a/PKGBUILD b/PKGBUILD
index 2f04e581f80c..645b260aca98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,23 +13,26 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
-md5sums=('SKIP')
-_gitname="${_plug}"
+sha1sums=('SKIP')
pkgver() {
- cd "${_gitname}"
+ cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
-build() {
- cd "${_gitname}"
+prepare() {
+ cd "${_plug}"
./autogen.sh
- ./configure --prefix=/usr --libdir=/usr/lib/vapoursynth
+}
+
+build() {
+ cd "${_plug}"
+ ./configure --libdir=/usr/lib/vapoursynth
make
}
package(){
- cd "${_gitname}"
+ cd "${_plug}"
make DESTDIR="${pkgdir}" install
- install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
+ install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
}