summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2019-01-06 20:37:20 +0100
committerPhilip Goto2019-01-06 20:37:20 +0100
commit9b1e78fc4e3c4d550f4d9329b7cb8ee13ea7ba2c (patch)
treec0d1a0f9d83e3f8cd8cf1617c62dc1ba11957c00
parent2f15ab0f6f4b781a51125981c5e12cfe07532aaa (diff)
downloadaur-9b1e78fc4e3c4d550f4d9329b7cb8ee13ea7ba2c.tar.gz
Update to 3.5.3
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92c4c95f004f..de1e95b692d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libanimation
pkgdesc = Library that provides animation calculations
- pkgver = 0.3.2
+ pkgver = 3.5.3
pkgrel = 1
url = https://github.com/endlessm/libanimation
arch = x86_64
@@ -9,10 +9,13 @@ pkgbase = libanimation
arch = armv7h
license = LGPL
makedepends = meson
+ makedepends = gmock
+ makedepends = gtest
+ makedepends = glib2
depends = glib2
conflicts = libanimation-git
- source = https://github.com/endlessm/libanimation/archive/Version_0.3.2.tar.gz
- md5sums = SKIP
+ source = https://github.com/endlessm/libanimation/archive/Release_3.5.3.tar.gz
+ sha256sums = d1a56061177a9519d16fd26796b747e27bac2948da1687f26032abb925cb1ea7
pkgname = libanimation
diff --git a/PKGBUILD b/PKGBUILD
index 4a0a60dc1225..7c8a855367fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=libanimation
-pkgver=0.3.2
+pkgver=3.5.3
pkgrel=1
pkgdesc="Library that provides animation calculations"
arch=(x86_64 i686 aarch64 armv7h)
url="https://github.com/endlessm/libanimation"
license=(LGPL)
depends=(glib2)
-makedepends=(meson)
+makedepends=(meson gmock gtest glib2)
conflicts=(libanimation-git)
-source=("https://github.com/endlessm/libanimation/archive/Version_${pkgver}.tar.gz")
-md5sums=(SKIP)
+source=("https://github.com/endlessm/libanimation/archive/Release_${pkgver}.tar.gz")
+sha256sums=('d1a56061177a9519d16fd26796b747e27bac2948da1687f26032abb925cb1ea7')
build() {
- rm -rf build
- arch-meson ${pkgname}-Version_${pkgver} build
- ninja -v -C build
+ arch-meson ${pkgname}-Release_${pkgver} build
+ ninja -C build
+}
+
+check() {
+ ninja -C build test
}
package() {
DESTDIR="${pkgdir}" ninja -C build install
-} \ No newline at end of file
+}