summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Wang2022-02-08 11:33:01 -0600
committerAnthony Wang2022-02-08 11:33:01 -0600
commit9b44e9266bdd2643608e2740ef737fc4553914b9 (patch)
tree26b71f25320cbf1d49070b04e194b44d8834b37b
parent1649d51e055c2014721788573aff678f12f33744 (diff)
downloadaur-9b44e9266bdd2643608e2740ef737fc4553914b9.tar.gz
Update PKGBUILD to match official digikam package
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD62
-rw-r--r--ffmpeg5.patch13
3 files changed, 50 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8439940d826f..859573a6a5f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = digikam-git
pkgdesc = An advanced digital photo management application
- pkgver = v7.2.0.beta1.r500.g9541292038
- pkgrel = 4
+ pkgver = v7.5.0.r345.g61141c0787
+ pkgrel = 1
url = https://www.digikam.org/
arch = i686
arch = x86_64
@@ -11,7 +11,6 @@ pkgbase = digikam-git
makedepends = eigen
makedepends = boost
makedepends = kdoctools
- makedepends = git
depends = lensfun
depends = opencv
depends = akonadi-contacts
@@ -24,9 +23,9 @@ pkgbase = digikam-git
depends = kcalendarcore
depends = qt5-xmlpatterns
depends = imagemagick
- depends = glu
depends = jasper
- depends = kservice-git
+ depends = glu
+ depends = perl-image-exiftool
optdepends = hugin: panorama tool
optdepends = qt5-imageformats: support for additional image formats (WEBP, TIFF)
optdepends = rawtherapee: RAW import
@@ -35,6 +34,8 @@ pkgbase = digikam-git
provides = digikam
conflicts = digikam
source = git+https://invent.kde.org/graphics/digikam.git
+ source = ffmpeg5.patch
sha256sums = SKIP
+ sha256sums = ef2601f9b2e668116a3643b4bd7ddcfc233ccfc747d813955423ca17b6a23dee
pkgname = digikam-git
diff --git a/PKGBUILD b/PKGBUILD
index 263a0bbfc842..77eb4d598af5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,49 @@
-# Maintainer: Chris Lane <aur at chrislane dot com>
+# Maintainer: Anthony Wang <ta180m at pm dot me>
+# Contributor: Chris Lane <aur at chrislane dot com>
+_pkgname=digikam
pkgname=digikam-git
-pkgver=v7.2.0.beta1.r500.g9541292038
-pkgrel=4
+pkgver=v7.5.0.r345.g61141c0787
+pkgrel=1
pkgdesc='An advanced digital photo management application'
-arch=('i686' 'x86_64')
-license=('GPL')
-url="https://www.digikam.org/"
-depends=(lensfun opencv akonadi-contacts knotifyconfig libksane kfilemetadata qtav marble-common
- threadweaver kcalendarcore qt5-xmlpatterns imagemagick glu jasper kservice-git)
-makedepends=(extra-cmake-modules doxygen eigen boost kdoctools git)
-optdepends=('hugin: panorama tool'
- 'qt5-imageformats: support for additional image formats (WEBP, TIFF)'
- 'rawtherapee: RAW import'
- 'darktable: RAW import'
+arch=(i686 x86_64)
+license=(GPL)
+url='https://www.digikam.org/'
+depends=(lensfun opencv akonadi-contacts knotifyconfig libksane kfilemetadata qtav marble-common threadweaver kcalendarcore
+ qt5-xmlpatterns imagemagick jasper glu perl-image-exiftool)
+makedepends=(extra-cmake-modules doxygen eigen boost kdoctools)
+optdepends=('hugin: panorama tool' 'qt5-imageformats: support for additional image formats (WEBP, TIFF)'
+ 'rawtherapee: RAW import' 'darktable: RAW import'
'perl: for digitaglinktree')
conflicts=('digikam')
provides=('digikam')
-source=('git+https://invent.kde.org/graphics/digikam.git')
-sha256sums=('SKIP')
+source=('git+https://invent.kde.org/graphics/digikam.git'
+ ffmpeg5.patch)
+sha256sums=('SKIP'
+ 'ef2601f9b2e668116a3643b4bd7ddcfc233ccfc747d813955423ca17b6a23dee')
pkgver() {
- cd digikam
+ cd ${_pkgname}
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ patch -d ${_pkgname} -p1 < ffmpeg5.patch
+}
+
build() {
- cmake \
- -B build \
- -S digikam \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_TESTING=OFF \
- -DENABLE_KFILEMETADATASUPPORT=ON \
- -DENABLE_MEDIAPLAYER=ON \
+ cmake -B build -S ${_pkgname} \
+ -DBUILD_TESTING=OFF \
+ -DENABLE_KFILEMETADATASUPPORT=ON \
+ -DENABLE_MEDIAPLAYER=ON \
-DENABLE_AKONADICONTACTSUPPORT=ON \
- -DENABLE_MYSQLSUPPORT=ON \
- -DENABLE_APPSTYLES=ON \
- -DENABLE_QWEBENGINE=ON \
- -Wno-dev
- make -C build
+ -DENABLE_MYSQLSUPPORT=ON \
+ -DENABLE_APPSTYLES=ON \
+ -DENABLE_QWEBENGINE=ON
+ cmake --build build
}
package() {
- make DESTDIR="${pkgdir}" install -C build
+ DESTDIR="$pkgdir" cmake --install build
}
# vim:set ts=2 sw=2 et:
diff --git a/ffmpeg5.patch b/ffmpeg5.patch
new file mode 100644
index 000000000000..cbdd368b38a2
--- /dev/null
+++ b/ffmpeg5.patch
@@ -0,0 +1,13 @@
+diff --git a/core/libs/threadimageio/video/videodecoder_p.h b/core/libs/threadimageio/video/videodecoder_p.h
+index 251e092809..d82926b77e 100644
+--- a/core/libs/threadimageio/video/videodecoder_p.h
++++ b/core/libs/threadimageio/video/videodecoder_p.h
+@@ -56,7 +56,7 @@ public:
+ AVFormatContext* pFormatContext;
+ AVCodecContext* pVideoCodecContext;
+ AVCodecParameters* pVideoCodecParameters;
+- AVCodec* pVideoCodec;
++ const AVCodec* pVideoCodec;
+ AVStream* pVideoStream;
+ AVFrame* pFrame;
+ quint8* pFrameBuffer;