summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2022-11-30 18:55:57 +0100
committerLuca Weiss2022-11-30 18:55:57 +0100
commit9b5a116dde2c73e1d4eb19f102aa35fb3b4c30c0 (patch)
treea0a53c9a26c23987b43ff1a868e9da76ffc53213
parent9a7f87f437a1da6f00c4f9223a7feecfe21f8356 (diff)
downloadaur-9b5a116dde2c73e1d4eb19f102aa35fb3b4c30c0.tar.gz
upgpkg: jellyfin-git 10.8.0.alpha5.r1140.g11707f8f08-1
Force dotnet-6.0, move backup line to jellyfin-server subpackage as per jellyfin package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD11
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6bd80868d5c8..7d8efc0f963a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = jellyfin-git
pkgdesc = The Free Software Media System
- pkgver = 10.6.0.r3918.g360d80c873
+ pkgver = 10.8.0.alpha5.r1140.g11707f8f08
pkgrel = 1
url = https://github.com/jellyfin/jellyfin
arch = i686
arch = x86_64
arch = armv6h
license = GPL2
- makedepends = dotnet-sdk>=3
+ makedepends = dotnet-sdk-6.0
makedepends = npm
makedepends = git
provides = jellyfin
conflicts = jellyfin
- backup = etc/conf.d/jellyfin
source = git+https://github.com/jellyfin/jellyfin.git
source = git+https://github.com/jellyfin/jellyfin-web.git
source = jellyfin.conf
@@ -27,8 +26,8 @@ pkgbase = jellyfin-git
sha512sums = 45a62b62d97b9a83289d4dfde684163b1bcf340c1921fb958e5a701812c61b392901841940c67e5fa5148783277d5b4dc65ba01d3a22e8f855ea62154ad9be33
pkgname = jellyfin-git
- depends = jellyfin-web-git=10.6.0.r3918.g360d80c873
- depends = jellyfin-server-git=10.6.0.r3918.g360d80c873
+ depends = jellyfin-web-git=10.8.0.alpha5.r1140.g11707f8f08
+ depends = jellyfin-server-git=10.8.0.alpha5.r1140.g11707f8f08
pkgname = jellyfin-web-git
pkgdesc = Jellyfin web client
@@ -37,10 +36,10 @@ pkgname = jellyfin-web-git
pkgname = jellyfin-server-git
pkgdesc = Jellyfin server component
- depends = dotnet-runtime>=3
- depends = aspnet-runtime>=3
+ depends = dotnet-runtime-6.0
+ depends = aspnet-runtime-6.0
depends = ffmpeg
depends = sqlite
provides = jellyfin-server
conflicts = jellyfin-server
-
+ backup = etc/conf.d/jellyfin
diff --git a/PKGBUILD b/PKGBUILD
index 933a45e16963..7adac1df48f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgbase=jellyfin-git
pkgname=(jellyfin-git jellyfin-web-git jellyfin-server-git)
-pkgver=10.6.0.r3918.g360d80c873
+pkgver=10.8.0.alpha5.r1140.g11707f8f08
pkgrel=1
pkgdesc='The Free Software Media System'
arch=('i686' 'x86_64' 'armv6h')
url='https://github.com/jellyfin/jellyfin'
license=('GPL2')
-makedepends=('dotnet-sdk>=3' 'npm' 'git')
+makedepends=('dotnet-sdk-6.0' 'npm' 'git')
provides=('jellyfin')
conflicts=('jellyfin')
source=('git+https://github.com/jellyfin/jellyfin.git'
@@ -19,7 +19,6 @@ source=('git+https://github.com/jellyfin/jellyfin.git'
'jellyfin.service'
'jellyfin.sysusers'
'jellyfin.tmpfiles')
-backup=('etc/conf.d/jellyfin')
sha512sums=('SKIP'
'SKIP'
'2aa97a1a7a8a447171b59be3e93183e09cbbc32c816843cc47c6777b9aec48bd9c1d9d354f166e0b000ad8d2e94e6e4b0559aa52e5c159abbc103ed2c5afa3f0'
@@ -45,6 +44,9 @@ build(){
# Disable dotnet telemetry
export DOTNET_CLI_TELEMETRY_OPTOUT=1
+ # Force dotnet to use 6.x when multiple SDKs are installed
+ dotnet new globaljson --sdk-version 6.0.0 --roll-forward latestMinor --force
+
dotnet build --configuration Release Jellyfin.Server
# Ideally, this would be run in package() with the --output variable pointing
# to "$pkgdir"/usr/lib/jellyfin, but this step fails in fakeroot.
@@ -63,7 +65,8 @@ package_jellyfin-git() {
package_jellyfin-server-git() {
pkgdesc="Jellyfin server component"
- depends=('dotnet-runtime>=3' 'aspnet-runtime>=3' 'ffmpeg' 'sqlite')
+ depends=('dotnet-runtime-6.0' 'aspnet-runtime-6.0' 'ffmpeg' 'sqlite')
+ backup=('etc/conf.d/jellyfin')
provides=('jellyfin-server')
conflicts=('jellyfin-server')