summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKarsten Pufahl2023-07-25 12:34:43 +0200
committerKarsten Pufahl2023-07-25 12:34:43 +0200
commit9b68fa12f583b155dd73e80318b783b071c9c688 (patch)
tree3294b73d22ca7fb5ff5655f2db62112c76b442c3
parent55e18a2c1f6f92464d8770958c693995650224f4 (diff)
downloadaur-9b68fa12f583b155dd73e80318b783b071c9c688.tar.gz
version 6.9.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--stm32cubemx.sh2
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3619509b350..eb889413c05f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = stm32cubemx
pkgdesc = graphical software configuration tool for STM32 microcontrollers that allows generating C initialization code
- pkgver = 6.8.1
+ pkgver = 6.9.0
pkgrel = 1
url = https://www.st.com/en/development-tools/stm32cubemx.html
arch = any
license = custom
makedepends = imagemagick
- depends = java-runtime=11
+ depends = java-runtime=20
depends = archlinux-java-run
depends = bash
options = !strip
- source = https://sw-center.st.com/packs/resource/library/stm32cube_mx_v681-lin.zip
+ source = https://sw-center.st.com/packs/resource/library/stm32cube_mx_v690-lin.zip
source = stm32cubemx.desktop
source = stm32cubemx.sh
- sha512sums = 985db6f67a5e41acc03eb68dfec4f9ec5874a3201a02ef36f5cb4a8cbbfd40f6a251106d695ffdb011ec37c3ebd3169d971516e730739a8e697abec6585eea37
+ sha512sums = fb51da651c5ccfa0fcbd799d89d11ac202deed2938f7675f1f3b78b5b2fc0ebcad3554783489394d265160e157aa9d669962d8aa583defb4a306a93af142667e
sha512sums = 83c67bef3e8f8434903fe0c067442cc7473459386fdcb0225af1b3a75fd75e2be393f91f877c8410f1055ca4ec531b2df707fcab10663cae382a7f4066c8548b
- sha512sums = 6a79222fecdd4e0321d4a460a746d704c25fa32a97fd6653adfb64447053b8985c9533caf2f92f8907ef4424aa19ce0bdff3911bbdc6bf744bb354baaa3d834c
+ sha512sums = e5b604754fcfc62f8b745dea8c921cc72d1ca1bc81bd3a2cd26f8871a86fad3598b60a4b3f5ff2503c76e6c2dcb9c9ce37e63ba84718c2d427a8de8003a318f2
pkgname = stm32cubemx
diff --git a/PKGBUILD b/PKGBUILD
index 254ad61da784..da7228bf59bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: laserK <echo 'Y29udGFjdEBrYXJzdGVucHVmYWhsLmRlCg==' | base64 -d>
pkgname=stm32cubemx
-pkgver=6.8.1
+pkgver=6.9.0
pkgrel=1
epoch=
pkgdesc="graphical software configuration tool for STM32 microcontrollers that allows generating C initialization code"
@@ -8,7 +8,7 @@ arch=(any)
url="https://www.st.com/en/development-tools/stm32cubemx.html"
license=('custom')
groups=()
-depends=('java-runtime=11'
+depends=('java-runtime=20'
'archlinux-java-run'
'bash')
makedepends=('imagemagick')
@@ -25,9 +25,9 @@ source=("https://sw-center.st.com/packs/resource/library/stm32cube_mx_v${pkgver/
"stm32cubemx.desktop"
"stm32cubemx.sh")
noextract=()
-sha512sums=('985db6f67a5e41acc03eb68dfec4f9ec5874a3201a02ef36f5cb4a8cbbfd40f6a251106d695ffdb011ec37c3ebd3169d971516e730739a8e697abec6585eea37'
+sha512sums=('fb51da651c5ccfa0fcbd799d89d11ac202deed2938f7675f1f3b78b5b2fc0ebcad3554783489394d265160e157aa9d669962d8aa583defb4a306a93af142667e'
'83c67bef3e8f8434903fe0c067442cc7473459386fdcb0225af1b3a75fd75e2be393f91f877c8410f1055ca4ec531b2df707fcab10663cae382a7f4066c8548b'
- '6a79222fecdd4e0321d4a460a746d704c25fa32a97fd6653adfb64447053b8985c9533caf2f92f8907ef4424aa19ce0bdff3911bbdc6bf744bb354baaa3d834c')
+ 'e5b604754fcfc62f8b745dea8c921cc72d1ca1bc81bd3a2cd26f8871a86fad3598b60a4b3f5ff2503c76e6c2dcb9c9ce37e63ba84718c2d427a8de8003a318f2')
validpgpkeys=()
package() {
diff --git a/stm32cubemx.sh b/stm32cubemx.sh
index 7021979baaf5..48d9ef64e334 100644
--- a/stm32cubemx.sh
+++ b/stm32cubemx.sh
@@ -1,2 +1,2 @@
#!/bin/sh
-exec archlinux-java-run --min 11 --max 11 -- -jar /opt/stm32cubemx/STM32CubeMX "$@" \ No newline at end of file
+exec archlinux-java-run --min 11 --max 20 -- -jar /opt/stm32cubemx/STM32CubeMX "$@"