summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2015-06-14 04:13:27 +0300
committerDet2015-06-14 04:14:15 +0300
commit9b9c2f2d81b5566f96b11326900fc6b524ea875e (patch)
tree3b051389a95a1fca6a1a05a8b1dafe3fe8d55a33
downloadaur-9b9c2f2d81b5566f96b11326900fc6b524ea875e.tar.gz
Initial import: 39.0b5-1
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD65
-rw-r--r--firefox-beta-bin-safe.desktop12
-rw-r--r--firefox-beta-bin.desktop12
-rw-r--r--firefox-beta-bin.install34
5 files changed, 165 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c74291a38aeb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = firefox-beta-bin
+ pkgdesc = Standalone web browser from mozilla.org - Beta
+ pkgver = 39.0b5
+ pkgrel = 1
+ url = https://www.mozilla.org/en-US/firefox/channel/#beta
+ install = firefox-beta-bin.install
+ arch = i686
+ arch = x86_64
+ license = MPL
+ license = GPL
+ license = LGPL
+ makedepends = pacman>=4.2.0
+ depends = alsa-lib
+ depends = dbus-glib
+ depends = desktop-file-utils
+ depends = gtk2
+ depends = hicolor-icon-theme
+ depends = icu
+ depends = libevent
+ depends = libvpx
+ depends = libxt
+ depends = mime-types
+ depends = nss
+ depends = sqlite
+ optdepends = gstreamer0.10-base: vorbis decoding, ogg demuxing
+ optdepends = gstreamer0.10-good: webm and mp4 demuxing
+ optdepends = gstreamer0.10-bad: aac, vp8 and opus decoding
+ optdepends = gstreamer0.10-ugly: h.264 and mp3 decoding
+ optdepends = gstreamer0.10-ffmpeg: more decoders
+ optdepends = libpulse: PulseAudio driver
+ optdepends = networkmanager: Location detection via available WiFi networks
+ source = firefox-beta-bin.desktop
+ source = firefox-beta-bin-safe.desktop
+ md5sums = 13bd50c37f55a83539a680ce83162468
+ md5sums = a85c53ccb2b78514f37833d288a20ba2
+ source_i686 = https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/39.0b5/linux-i686/en-US/firefox-39.0b5.tar.bz2
+ md5sums_i686 = 8dfd426e1aae4cad68d83af4c1fa8cbf
+ source_x86_64 = https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/39.0b5/linux-x86_64/en-US/firefox-39.0b5.tar.bz2
+ md5sums_x86_64 = ed397d8f0c9f3a72eb6ae695e370ae45
+
+pkgname = firefox-beta-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1815a6e196f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Det <nimetonmaili g-mail>
+# Contributors: Achilleas Pipinellis, speed145a, Schnouki
+
+pkgname=firefox-beta-bin
+pkgver=39.0b5
+_major=${pkgver/rc*}
+_build=${pkgver/*rc}
+pkgrel=1
+pkgdesc="Standalone web browser from mozilla.org - Beta"
+arch=('i686' 'x86_64')
+url="https://www.mozilla.org/en-US/firefox/channel/#beta"
+license=('MPL' 'GPL' 'LGPL')
+depends=('alsa-lib' 'dbus-glib' 'desktop-file-utils' 'gtk2' 'hicolor-icon-theme'
+ 'icu' 'libevent' 'libvpx' 'libxt' 'mime-types' 'nss' 'sqlite')
+optdepends=('gstreamer0.10-base: vorbis decoding, ogg demuxing'
+ 'gstreamer0.10-good: webm and mp4 demuxing'
+ 'gstreamer0.10-bad: aac, vp8 and opus decoding'
+ 'gstreamer0.10-ugly: h.264 and mp3 decoding'
+ 'gstreamer0.10-ffmpeg: more decoders'
+ 'libpulse: PulseAudio driver'
+ 'networkmanager: Location detection via available WiFi networks')
+makedepends=('pacman>=4.2.0')
+install=$pkgname.install
+source=("$pkgname.desktop"
+ "$pkgname-safe.desktop")
+source_i686=("https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/linux-i686/en-US/firefox-$pkgver.tar.bz2")
+source_x86_64=("https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/linux-x86_64/en-US/firefox-$pkgver.tar.bz2")
+md5sums=('13bd50c37f55a83539a680ce83162468'
+ 'a85c53ccb2b78514f37833d288a20ba2')
+md5sums_i686=('8dfd426e1aae4cad68d83af4c1fa8cbf')
+md5sums_x86_64=('ed397d8f0c9f3a72eb6ae695e370ae45')
+# RC
+if [[ $_build = ? ]]; then
+ source_i686=("https://ftp.mozilla.org/pub/mozilla.org/firefox/candidates/$_major-candidates/build$_build/linux-i686/en-US/firefox-$_major.tar.bz2")
+ source_x86_64=("https://ftp.mozilla.org/pub/mozilla.org/firefox/candidates/$_major-candidates/build$_build/linux-x86_64/en-US/firefox-$_major.tar.bz2")
+fi
+
+package() {
+ # Create directories
+ msg2 "Creating directory structure..."
+ mkdir -p "$pkgdir"/usr/bin
+ mkdir -p "$pkgdir"/usr/share/applications
+ mkdir -p "$pkgdir"/usr/share/icons/hicolor/128x128/apps
+ mkdir -p "$pkgdir"/opt
+
+ msg2 "Moving stuff in place..."
+ # Install
+ cp -r firefox/ "$pkgdir"/opt/$pkgname-$pkgver
+
+ # /usr/bin link
+ ln -s /opt/$pkgname-$pkgver/firefox "$pkgdir"/usr/bin/$pkgname
+
+ # Desktops
+ install -m644 *.desktop "$pkgdir"/usr/share/applications/
+
+ # Icons
+ for i in 16x16 22x22 24x24 32x32 48x48 256x256; do
+ install -d "$pkgdir"/usr/share/icons/hicolor/$i/apps/
+ ln -s /opt/$pkgname-$pkgver/browser/chrome/icons/default/default${i/x*}.png \
+ "$pkgdir"/usr/share/icons/hicolor/$i/apps/$pkgname.png
+ done
+
+ ln -s /opt/$pkgname-$pkgver/browser/icons/mozicon128.png \
+ "$pkgdir"/usr/share/icons/hicolor/128x128/apps/$pkgname.png
+}
diff --git a/firefox-beta-bin-safe.desktop b/firefox-beta-bin-safe.desktop
new file mode 100644
index 000000000000..e53fadf2407c
--- /dev/null
+++ b/firefox-beta-bin-safe.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=Firefox Beta - Safe Mode
+GenericName=Web Browser - Safe Mode
+Comment=Browse the World Wide Web in Safe Mode
+Exec=firefox-beta-bin -safe-mode %u
+Icon=firefox-beta-bin
+Terminal=false
+Type=Application
+MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;
+StartupNotify=false
+Categories=Network;WebBrowser;
+StartupWMClass=Firefox
diff --git a/firefox-beta-bin.desktop b/firefox-beta-bin.desktop
new file mode 100644
index 000000000000..f6bff4dec8a3
--- /dev/null
+++ b/firefox-beta-bin.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=Firefox Beta
+GenericName=Web Browser
+Comment=Browse the World Wide Web
+Exec=firefox-beta-bin %u
+Icon=firefox-beta-bin
+Terminal=false
+Type=Application
+MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;
+StartupNotify=false
+Categories=Network;WebBrowser;
+StartupWMClass=Firefox
diff --git a/firefox-beta-bin.install b/firefox-beta-bin.install
new file mode 100644
index 000000000000..ab05bb2f045b
--- /dev/null
+++ b/firefox-beta-bin.install
@@ -0,0 +1,34 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE$1:${bold} $2${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+_update() {
+ msg_blue "Updating desktop database..."
+ update-desktop-database -q
+ msg_blue "Updating icon cache.."
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_install() {
+ _update
+ note 1 "This package installs side-by-side with [extra]'s firefox."
+ note 2 "The binary is called 'firefox-beta-bin'."
+}
+
+post_upgrade() {
+ _update
+}
+
+post_remove() {
+ post_upgrade
+}