summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2021-01-23 14:17:13 +0100
committerFabioLolix2021-01-23 14:17:13 +0100
commit9b9e86650ae4e2b4b933a6d569fc10df6c6c9a5b (patch)
treea0ce05b973adf63943ca0f0f440cc278f832c9e4
parentc9b78e1518f7bd8a595b1a5e3a82354465a80f0d (diff)
downloadaur-9b9e86650ae4e2b4b933a6d569fc10df6c6c9a5b.tar.gz
correct depends, makedepends, configure
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 404caa024213..a7c67b27de52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = glimpse-editor-git
pkgdesc = Fork of the GNU Image Manipulation Program
- pkgver = r44029.903c9f0521
- pkgrel = 1
+ pkgver = r44038.c39feb48d0
+ pkgrel = 2
url = https://glimpse-editor.org/
arch = i686
arch = x86_64
@@ -22,10 +22,10 @@ pkgbase = glimpse-editor-git
makedepends = aalib
makedepends = appstream-glib
makedepends = xdg-utils
+ makedepends = xorg-server-xvfb
depends = gegl
depends = libmypaint
depends = gtk2
- depends = pygtk
depends = openexr
depends = poppler-glib
depends = poppler-data
diff --git a/PKGBUILD b/PKGBUILD
index c2a02ed0c044..c420a502d5a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
pkgname=glimpse-editor-git
-pkgver=r44029.903c9f0521
-pkgrel=1
+pkgver=r44038.c39feb48d0
+pkgrel=2
pkgdesc="Fork of the GNU Image Manipulation Program"
arch=(i686 x86_64)
url="https://glimpse-editor.org/"
license=(GPL3 LGPL)
-depends=(gegl libmypaint gtk2 pygtk openexr
+depends=(gegl libmypaint gtk2 openexr
poppler-glib poppler-data mypaint-brushes1
)
makedepends=(git intltool libxslt gtk-doc libxslt
ghostscript libxpm libheif libwebp libmng libwmf iso-codes aalib
- appstream-glib xdg-utils
+ appstream-glib xdg-utils xorg-server-xvfb
)
optdepends=('gutenprint: for sophisticated printing only as glimpse has built-in cups print support'
'alsa-lib: for MIDI event controller module'
@@ -42,7 +42,7 @@ prepare() {
_mypaintver=$(echo /usr/lib/libmypaint-*.so | grep -o -E '\-[0-9]+(\.[0-9]+)*' | head -1)
sed -i "s|\\(libmypaint\\)\\( >= libmypaint_required_version\\)|\\1${_mypaintver}\\2|g" configure.ac
- ./autogen.sh
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
@@ -54,8 +54,11 @@ build() {
--libexecdir=/usr/bin \
--enable-mp \
--enable-gimp-console \
+ --disable-check-update \
--enable-gtk-doc \
--disable-python \
+ --without-webkit \
+ --with-xmc \
--with-bug-report-url=https://aur.archlinux.org/packages/glimpse-editor-git/ \
--with-openexr