summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Conseil2015-06-13 00:18:02 +0200
committerSimon Conseil2015-06-13 00:18:02 +0200
commit9b9e8ffca7127e760b8065fe0984519f3ccac5dc (patch)
tree4c554f3ee007704a1143031632ae6f0268e9f22f
downloadaur-9b9e8ffca7127e760b8065fe0984519f3ccac5dc.tar.gz
Initial import
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
3 files changed, 50 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..6cd0971a077d
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-pilkit
+ pkgdesc = A collection of utilities and processors for the Python Imaging Libary
+ pkgver = 1.1.12
+ pkgrel = 1
+ url = https://github.com/matthewwithanm/pilkit/
+ arch = any
+ license = BSD
+ depends = python2
+ depends = python2-pillow
+ source = http://pypi.python.org/packages/source/p/pilkit/pilkit-1.1.12.tar.gz
+ md5sums = db659fe027a4c48196bd46ae9263e14b
+
+pkgname = python2-pilkit
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6cd0971a077d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-pilkit
+ pkgdesc = A collection of utilities and processors for the Python Imaging Libary
+ pkgver = 1.1.12
+ pkgrel = 1
+ url = https://github.com/matthewwithanm/pilkit/
+ arch = any
+ license = BSD
+ depends = python2
+ depends = python2-pillow
+ source = http://pypi.python.org/packages/source/p/pilkit/pilkit-1.1.12.tar.gz
+ md5sums = db659fe027a4c48196bd46ae9263e14b
+
+pkgname = python2-pilkit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8eb582ba25b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Simon Conseil <contact+aur at saimon dot org>
+pkgname=python2-pilkit
+_pkgname=pilkit
+pkgver=1.1.12
+pkgrel=1
+pkgdesc="A collection of utilities and processors for the Python Imaging Libary"
+arch=('any')
+url="https://github.com/matthewwithanm/pilkit/"
+license=('BSD')
+depends=('python2' 'python2-pillow')
+source=("http://pypi.python.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz")
+md5sums=('db659fe027a4c48196bd46ae9263e14b')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
+ install -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}
+
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: