summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2019-06-25 08:36:11 +1000
committerRod Kay2019-06-25 08:36:11 +1000
commit9bbea54d6b9fb7366f1865474be1b9665ebe5739 (patch)
treef6a6b11be7945ecfd920d97c22abf187e4c7de84
parent3b18863a59b2777fc484bdea6d68aece3c51fa0d (diff)
downloadaur-9bbea54d6b9fb7366f1865474be1b9665ebe5739.tar.gz
Add a desktop config file.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
-rw-r--r--gps.desktop28
3 files changed, 39 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4ef022fd06e..cb6230b88cdc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -25,12 +25,14 @@ pkgbase = gnat-gps
source = patch-docs-Makefile.in
source = xref-docgen.adb-patch
source = src_contexts.adb-patch
+ source = gps.desktop
sha1sums = 203427f62483f7fda557a0be4bac9045a55b351d
sha1sums = 6b32f1aa7cc443bcaf268ef13fa46e3b0fdf147d
sha1sums = 763584d9a931887eff11151310504c02df279224
sha1sums = 60813145324cd5ea9f081648da10cffd99f87586
sha1sums = e166ed6513465f59f433eac8f759afcd190ab853
sha1sums = bd80d0f84c128e1e0d6a1aa3ac4b419226a4c616
+ sha1sums = 1f4ee00408551af23eec12488188016ffee17c72
pkgname = gnat-gps
diff --git a/PKGBUILD b/PKGBUILD
index 2d9bba99331a..abfe1b9c840d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,14 +23,16 @@ source=(https://github.com/AdaCore/gps/archive/3b331d05ecf8b0d0e76d0b264c8f5c4fa
patch-Makefile.in
patch-docs-Makefile.in
xref-docgen.adb-patch
- src_contexts.adb-patch)
+ src_contexts.adb-patch
+ gps.desktop)
sha1sums=('203427f62483f7fda557a0be4bac9045a55b351d'
'6b32f1aa7cc443bcaf268ef13fa46e3b0fdf147d'
'763584d9a931887eff11151310504c02df279224'
'60813145324cd5ea9f081648da10cffd99f87586'
'e166ed6513465f59f433eac8f759afcd190ab853'
- 'bd80d0f84c128e1e0d6a1aa3ac4b419226a4c616')
+ 'bd80d0f84c128e1e0d6a1aa3ac4b419226a4c616'
+ '1f4ee00408551af23eec12488188016ffee17c72')
gps_version="3b331d05ecf8b0d0e76d0b264c8f5c4fa7bca3d3"
@@ -86,4 +88,9 @@ package()
export PATH=$srcdir/gps/temp_bin:$PATH
make DESTDIR="$pkgdir/" install
+
+ ## Add the desktop config.
+ #
+ mkdir -p $pkgdir/usr/share/applications
+ cp $srcdir/gps.desktop $pkgdir/usr/share/applications
}
diff --git a/gps.desktop b/gps.desktop
new file mode 100644
index 000000000000..543e1357ad62
--- /dev/null
+++ b/gps.desktop
@@ -0,0 +1,28 @@
+[Desktop Entry]
+
+# The type as listed above
+Type=Application
+
+# The version of the desktop entry specification to which this file complies
+Version=1.0
+
+# The name of the application
+Name=GPS
+
+# A comment which can/will be used as a tooltip
+Comment=Gnat Programming Studio
+
+# The path to the folder in which the executable is run
+Path=~
+
+# The executable of the application, possibly with arguments.
+Exec=gps
+
+# The name of the icon that will be used to display this entry
+Icon=/usr/share/gps/gps-splash.png
+
+# Describes whether this application needs to be run in a terminal or not
+Terminal=false
+
+# Describes the categories in which this entry should be shown
+Categories=Development;Languages;Ada;