summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArpan Kapoor2015-10-15 01:58:30 +0530
committerArpan Kapoor2015-10-15 01:58:30 +0530
commit9bcdb3cce72305b348ba814c1fc65c1529df0f93 (patch)
treed3417c8edbdf3fc53e5a454960fd7904435e4d1b
parent8c7d13f35f681c4415e832b943303dd7990481e1 (diff)
downloadaur-9bcdb3cce72305b348ba814c1fc65c1529df0f93.tar.gz
Change patch repository
Upstream patch repository was updated to work with v2.5
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD30
-rw-r--r--config98
3 files changed, 122 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a5d1f31519b..200e527107d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = hostapd-rtl871xdrv
pkgdesc = IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
pkgver = 2.5
- pkgrel = 1
+ pkgrel = 2
url = http://w1.fi/hostapd/
install = hostapd.install
arch = i686
arch = x86_64
- arch = armv7h
+ arch = arm
arch = armv6h
+ arch = armv7h
license = custom
makedepends = git
depends = openssl
@@ -16,12 +17,14 @@ pkgbase = hostapd-rtl871xdrv
conflicts = hostapd
options = emptydirs
source = http://w1.fi/releases/hostapd-2.5.tar.gz
- source = git://github.com/arpankapoor/hostapd-rtl871xdrv.git
+ source = git://github.com/pritambaral/hostapd-rtl871xdrv.git
+ source = config
source = hostapd.service
source = hostapd-2.3-noscan.patch
source = openvswitch.patch
md5sums = 69f9cec3f76d74f402864a43e4f8624f
md5sums = SKIP
+ md5sums = 43c0ec1d8b4d4e46f468bc161bb05c4b
md5sums = 380042b9cf4950e34ed34b3093ab9e7f
md5sums = eaf8e48a9a63b5902fddadff2b8933fa
md5sums = a0802a604ed957078da0e14863df74f0
diff --git a/PKGBUILD b/PKGBUILD
index 82716a4e9e80..dd1815e6c1c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,48 @@
-# Maintainer: Arpan Kapoor
+# Maintainer: Arpan Kapoor <k dot arpan26 at gmail dot com>
pkgname=hostapd-rtl871xdrv
+_pkgname=${pkgname%-*}
pkgver=2.5
-pkgrel=1
+pkgrel=2
pkgdesc="IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator"
-arch=('i686' 'x86_64' 'armv7h' 'armv6h')
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
url="http://w1.fi/hostapd/"
license=('custom')
depends=('openssl' 'libnl')
makedepends=('git')
provides=('hostapd')
conflicts=('hostapd')
-install=hostapd.install
+install=${_pkgname}.install
options=(emptydirs)
-source=(http://w1.fi/releases/hostapd-$pkgver.tar.gz
- git://github.com/arpankapoor/hostapd-rtl871xdrv.git
+source=(http://w1.fi/releases/${_pkgname}-${pkgver}.tar.gz
+ git://github.com/pritambaral/hostapd-rtl871xdrv.git
+ config
hostapd.service
hostapd-2.3-noscan.patch
openvswitch.patch)
md5sums=('69f9cec3f76d74f402864a43e4f8624f'
'SKIP'
+ '43c0ec1d8b4d4e46f468bc161bb05c4b'
'380042b9cf4950e34ed34b3093ab9e7f'
'eaf8e48a9a63b5902fddadff2b8933fa'
'a0802a604ed957078da0e14863df74f0')
prepare() {
- cd hostapd-$pkgver
+ cd ${_pkgname}-$pkgver
patch -p1 -i $srcdir/hostapd-2.3-noscan.patch
patch -p1 -i $srcdir/openvswitch.patch
# Realtek patch
patch -Np1 -i $srcdir/hostapd-rtl871xdrv/rtlxdrv.patch
- cp $srcdir/hostapd-rtl871xdrv/driver_* src/drivers/
- cp $srcdir/hostapd-rtl871xdrv/.config hostapd/.config
}
build() {
- cd hostapd-$pkgver/hostapd
+ cd ${_pkgname}-$pkgver/hostapd
+ cp ../../config .config
+
+ # Enable the driver
+ echo "CONFIG_DRIVER_RTW=y" >> .config
+
sed -i 's#/etc/hostapd#/etc/hostapd/hostapd#' hostapd.conf
export CFLAGS="$CFLAGS $(pkg-config --cflags libnl-3.0)"
make
@@ -46,10 +52,10 @@ package() {
# Systemd unit
install -Dm644 hostapd.service "$pkgdir/usr/lib/systemd/system/hostapd.service"
- cd hostapd-$pkgver
+ cd ${_pkgname}-$pkgver
# License
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/hostapd/COPYING"
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/${_pkgname}/COPYING"
cd hostapd
diff --git a/config b/config
new file mode 100644
index 000000000000..0fcad7af4f91
--- /dev/null
+++ b/config
@@ -0,0 +1,98 @@
+# Example hostapd build time configuration
+#
+# This file lists the configuration options that are used when building the
+# hostapd binary. All lines starting with # are ignored. Configuration option
+# lines must be commented out complete, if they are not to be included, i.e.,
+# just setting VARIABLE=n is not disabling that variable.
+#
+# This file is included in Makefile, so variables like CFLAGS and LIBS can also
+# be modified from here. In most cass, these lines should use += in order not
+# to override previous values of the variables.
+
+# Driver interface for Host AP driver
+CONFIG_DRIVER_HOSTAP=y
+
+# Driver interface for wired authenticator
+CONFIG_DRIVER_WIRED=y
+
+# Driver interface for Prism54 driver
+CONFIG_DRIVER_PRISM54=y
+
+# IEEE 802.11F/IAPP
+CONFIG_IAPP=y
+
+# WPA2/IEEE 802.11i RSN pre-authentication
+CONFIG_RSN_PREAUTH=y
+
+# PeerKey handshake for Station to Station Link (IEEE 802.11e DLS)
+CONFIG_PEERKEY=y
+
+# IEEE 802.11w (management frame protection)
+# This version is an experimental implementation based on IEEE 802.11w/D1.0
+# draft and is subject to change since the standard has not yet been finalized.
+# Driver support is also needed for IEEE 802.11w.
+CONFIG_IEEE80211W=y
+
+# Integrated EAP server
+CONFIG_EAP=y
+
+# EAP-MD5 for the integrated EAP server
+CONFIG_EAP_MD5=y
+
+# EAP-TLS for the integrated EAP server
+CONFIG_EAP_TLS=y
+
+# EAP-MSCHAPv2 for the integrated EAP server
+CONFIG_EAP_MSCHAPV2=y
+
+# EAP-PEAP for the integrated EAP server
+CONFIG_EAP_PEAP=y
+
+# EAP-GTC for the integrated EAP server
+CONFIG_EAP_GTC=y
+
+# EAP-TTLS for the integrated EAP server
+CONFIG_EAP_TTLS=y
+
+# EAP-SIM for the integrated EAP server
+CONFIG_EAP_SIM=y
+
+# EAP-AKA for the integrated EAP server
+CONFIG_EAP_AKA=y
+
+# EAP-PAX for the integrated EAP server
+CONFIG_EAP_PAX=y
+
+# EAP-PSK for the integrated EAP server (this is _not_ needed for WPA-PSK)
+CONFIG_EAP_PSK=y
+
+# EAP-SAKE for the integrated EAP server
+CONFIG_EAP_SAKE=y
+
+# EAP-GPSK for the integrated EAP server
+CONFIG_EAP_GPSK=y
+# Include support for optional SHA256 cipher suite in EAP-GPSK
+CONFIG_EAP_GPSK_SHA256=y
+
+# PKCS#12 (PFX) support (used to read private key and certificate file from
+# a file that usually has extension .p12 or .pfx)
+CONFIG_PKCS12=y
+
+# RADIUS authentication server. This provides access to the integrated EAP
+# server from external hosts using RADIUS.
+CONFIG_RADIUS_SERVER=y
+
+# Build IPv6 support for RADIUS operations
+CONFIG_IPV6=y
+
+CONFIG_DRIVER_NL80211=y
+
+CONFIG_IEEE80211N=y
+
+CONFIG_LIBNL32=y
+
+CONFIG_ACS=y
+
+CONFIG_IEEE80211AC=y
+
+CONFIG_OPENVSWITCH=y