summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Lane2015-06-09 17:26:12 +0100
committerJohn Lane2015-06-09 17:26:12 +0100
commit9bd027a96d7a00304f4324ded326bb3e486bd9eb (patch)
tree58e1a2e3371895f5abc7dbbd7b52a8b987927e84
downloadaur-9bd027a96d7a00304f4324ded326bb3e486bd9eb.tar.gz
Initial import
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD42
3 files changed, 72 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..d5ca1e503a3a
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = dcc
+ pkgdesc = Distributed Checksum Clearinghouse spam tool
+ pkgver = 1.3.158
+ pkgrel = 1
+ url = http://www.rhyolite.com/anti-spam/dcc/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = sh
+ source = http://www.rhyolite.com/anti-spam/dcc/source/old/dcc-1.3.158.tar.Z
+ source = http://www.rhyolite.com/dcc/LICENSE
+
+pkgname = dcc
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..654a213acda6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = dcc
+ pkgdesc = Distributed Checksum Clearinghouse spam tool
+ pkgver = 1.3.158
+ pkgrel = 1
+ url = http://www.rhyolite.com/anti-spam/dcc/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = sh
+ source = http://www.rhyolite.com/anti-spam/dcc/source/old/dcc-1.3.158.tar.Z
+ source = http://www.rhyolite.com/dcc/LICENSE
+ sha256sums = 596bb4a02800a87501818215e61ac877e4d5a31ec0c8c227f23438f6b6b831c6
+ sha256sums = 8bce5cc14bd52293e9b6331cbd2979a12d667bbea615e65b18608b690f7b5fef
+
+pkgname = dcc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33ae1f86daff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: John Lane <archlinux at jelmail dot com>
+# Previously: Contributor: Nathan Owe <ndowens.aur at gmail dot com>
+
+pkgname=dcc
+pkgver=1.3.158
+pkgrel=1
+pkgdesc="Distributed Checksum Clearinghouse spam tool"
+url="http://www.rhyolite.com/anti-spam/dcc/"
+arch=('i686' 'x86_64')
+license="custom"
+depends=('sh')
+source=(http://www.rhyolite.com/anti-spam/dcc/source/old/$pkgname-$pkgver.tar.Z \
+ http://www.rhyolite.com/dcc/LICENSE)
+sha256sums=('596bb4a02800a87501818215e61ac877e4d5a31ec0c8c227f23438f6b6b831c6'
+ '8bce5cc14bd52293e9b6331cbd2979a12d667bbea615e65b18608b690f7b5fef')
+
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ CPPFLAGS="$CPPFLAGS -O2" # https://bbs.archlinux.org/viewtopic.php?id=182812
+ ./configure --with-installroot=${pkgdir} \
+ --mandir=/usr/share/man --homedir=/opt/dcc \
+ --bindir=/usr/bin --libexecdir=/usr/lib/dcc
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ MAKEFLAGS="$MAKEFLAGS -j1" # AUR comment zmeYski 2014-10-14 17:57
+ make DESTDIR=${pkgdir}/ install
+ install -d $pkgdir/usr/share/licenses/$pkgname
+ install -Dm644 $srcdir/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+ #Fix file permissions
+ find $pkgdir/ -group bin -exec chgrp root {} \;
+ find $pkgdir/ -user bin -exec chown root {} \;
+ find $pkgdir/opt/dcc -type f -exec chmod 644 {} \;
+ chmod 755 $pkgdir/opt/dcc/log
+
+
+}
+