summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Mueller2019-01-20 22:47:38 +0100
committerAnton Mueller2019-01-20 22:47:38 +0100
commit9bd5bae3d47880a398672e661997babb18c5f355 (patch)
treeb7c566ae84bd3ec1dee214fd7d97a883c65d3f62
downloadaur-9bd5bae3d47880a398672e661997babb18c5f355.tar.gz
added PKGBUILD .SRCINFO to git
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f103b6ccf76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = yubikey-full-disk-encryption-git
+ pkgdesc = Use YubiKey to unlock a LUKS partition
+ pkgver = r82.a2843e1
+ pkgrel = 1
+ url = https://github.com/agherzan/yubikey-full-disk-encryption
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = yubikey-personalization
+ depends = cryptsetup
+ depends = udisks2
+ depends = expect
+ backup = etc/ykfde.conf
+ source = git+https://github.com/agherzan/yubikey-full-disk-encryption.git
+ sha256sums = SKIP
+
+pkgname = yubikey-full-disk-encryption-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6544b045cb5c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer therojam <archlinux@therojam.xyz>
+
+pkgname=yubikey-full-disk-encryption-git
+pkgver=r82.a2843e1
+pkgrel=1
+pkgdesc='Use YubiKey to unlock a LUKS partition'
+arch=('any')
+url='https://github.com/agherzan/yubikey-full-disk-encryption'
+license=('GPL')
+depends=('yubikey-personalization' 'cryptsetup' 'udisks2' 'expect')
+makedepends=('git')
+backup=('etc/ykfde.conf')
+source=('git+https://github.com/agherzan/yubikey-full-disk-encryption.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ }
+
+package() {
+ cd "${pkgname}"
+ make DESTDIR="${pkgdir}" instal
+ }