summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspider-mario2023-11-05 19:42:22 +0100
committerspider-mario2023-11-05 19:42:41 +0100
commit9bfcf9dbb9decf7ac6211dde59bad5e88c286ecc (patch)
treecaec3397a5c7e618bf2eeefd42e1a7ca4ad9d91a
parent62ec8c650bda0608f2a1e8400578c58fc4a5b881 (diff)
downloadaur-9bfcf9dbb9decf7ac6211dde59bad5e88c286ecc.tar.gz
opencv4
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
-rw-r--r--opencv4.patch12
3 files changed, 24 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f143b8153f20..cabcea997436 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = ssimulacra
pkgdesc = Structural SIMilarity Unveiling Local And Compression Related Artifacts
pkgver = 0.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/cloudinary/ssimulacra
arch = x86_64
license = Apache
makedepends = boost
- depends = opencv2
+ depends = opencv
depends = boost-libs
- source = git+https://github.com/cloudinary/ssimulacra.git#commit=4c92d4184a8917fecdecccb68a8231cdfbc24249
+ source = git+https://github.com/cloudinary/ssimulacra.git#commit=375726b13f9dec2a01950e6710e7e9f488c52ea3
+ source = opencv4.patch
sha512sums = SKIP
+ sha512sums = 3d08d467c71b1bb64ad232a530fb970467c76ac745d7bd75f6df3c8823bf9a54448b98287098cec6076e80093b745b9f26e085048ed49afe7998c0254de3c77b
pkgname = ssimulacra
-
diff --git a/PKGBUILD b/PKGBUILD
index 1d559bd8479c..dc4a9797f4ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,21 @@
# Maintainer: spider-mario <spidermario@free.fr>
pkgname=ssimulacra
pkgver=0.2
-pkgrel=1
+pkgrel=2
pkgdesc="Structural SIMilarity Unveiling Local And Compression Related Artifacts"
arch=('x86_64')
url="https://github.com/cloudinary/ssimulacra"
license=('Apache')
-depends=('opencv2' 'boost-libs')
+depends=('opencv' 'boost-libs')
makedepends=('boost')
-source=('git+https://github.com/cloudinary/ssimulacra.git#commit=4c92d4184a8917fecdecccb68a8231cdfbc24249')
-sha512sums=('SKIP')
+source=('git+https://github.com/cloudinary/ssimulacra.git#commit=375726b13f9dec2a01950e6710e7e9f488c52ea3'
+ 'opencv4.patch')
+sha512sums=('SKIP'
+ '3d08d467c71b1bb64ad232a530fb970467c76ac745d7bd75f6df3c8823bf9a54448b98287098cec6076e80093b745b9f26e085048ed49afe7998c0254de3c77b')
prepare() {
cd "$pkgname"
- perl -pe 's/(?:C|LD)FLAGS\K=/+=/g; s/ -lopencv_imgcodecs//' -i Makefile
+ git apply --3way "$srcdir"/opencv4.patch
}
build() {
diff --git a/opencv4.patch b/opencv4.patch
new file mode 100644
index 000000000000..4aa2918cb65a
--- /dev/null
+++ b/opencv4.patch
@@ -0,0 +1,12 @@
+diff --git a/Makefile b/Makefile
+index 0ce8ec3..898d428 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,5 +1,5 @@
+-CFLAGS=`pkg-config --cflags opencv`
+-LDFLAGS=`pkg-config --libs-only-L opencv` -lopencv_core -lopencv_highgui -lopencv_imgcodecs -lopencv_imgproc
++CFLAGS+=`pkg-config --cflags opencv4`
++LDFLAGS+=`pkg-config --libs-only-L opencv4` -lopencv_core -lopencv_highgui -lopencv_imgcodecs -lopencv_imgproc
+ ssimulacra: ssimulacra.cpp
+ g++ -std=c++11 -O2 -fstrict-aliasing -ffast-math $(CFLAGS) ssimulacra.cpp $(LDFLAGS) -o ssimulacra
+ clean: