summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorananaso2021-04-18 17:54:46 -0700
committerananaso2021-04-18 17:54:46 -0700
commit9c029d562b71520b8c3f8417d0588c45243a9be6 (patch)
tree73e96f002ea005be1454fa8bb46b97813bd4e51b
parentb66342c32cd92f312f6d23a5a4f21bf90d4ce40d (diff)
downloadaur-9c029d562b71520b8c3f8417d0588c45243a9be6.tar.gz
fixed incorrect pkgname
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3bf77bb74270..c1612a738d05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = gnome-shell-screenshotlocations-extension-git
+pkgbase = gnome-shell-extension-screenshotlocations-git
pkgdesc = A GNOME extension for changing the screenshot output directory
pkgver = r31.dfdcf12
pkgrel = 1
@@ -12,5 +12,5 @@ pkgbase = gnome-shell-screenshotlocations-extension-git
source = git+https://codeberg.org/kiyui/gnome-shell-screenshotlocations-extension.git
sha256sums = SKIP
-pkgname = gnome-shell-screenshotlocations-extension-git
+pkgname = gnome-shell-extension-screenshotlocations-git
diff --git a/PKGBUILD b/PKGBUILD
index eb762d6c4c4d..7187cd51120c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: ananaso <adavidson+aur@protonmail.ch>
# Contributor: 4679kun <4679kun@outlook.com>
-pkgname=gnome-shell-screenshotlocations-extension-git
+pkgname=gnome-shell-extension-screenshotlocations-git
+_reponame=gnome-shell-screenshotlocations-extension
pkgver=r31.dfdcf12
pkgrel=1
pkgdesc="A GNOME extension for changing the screenshot output directory"
@@ -14,17 +15,17 @@ source=('git+'${url}'.git')
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgname%-git}"
+ cd "${srcdir}/${_reponame}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/${_reponame}"
arch-meson --buildtype=plain build
ninja -C build
}
package() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/${_reponame}"
DESTDIR="$pkgdir" ninja -C build install
}