summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Falkenberg2022-02-02 11:14:32 +0100
committerRobert Falkenberg2022-02-02 11:14:32 +0100
commit9c030eaff634d2370cd37bfd2793c03698869a63 (patch)
treecd2ca54651a4c575cf762be9f88f0c4ce68da67c
downloadaur-9c030eaff634d2370cd37bfd2793c03698869a63.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a17ac3958e14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libp11-static
+ pkgdesc = A library implementing a small layer on top of the PKCS11 API (with static libs)
+ pkgver = 0.4.11
+ pkgrel = 1
+ url = https://github.com/OpenSC/libp11/wiki
+ arch = x86_64
+ license = LGPL
+ depends = openssl
+ provides = libp11=0.4.11
+ conflicts = libp11
+ options = staticlibs
+ source = https://github.com/OpenSC/libp11/releases/download/libp11-0.4.11/libp11-0.4.11.tar.gz
+ source = https://github.com/OpenSC/libp11/releases/download/libp11-0.4.11/libp11-0.4.11.tar.gz.asc
+ validpgpkeys = AC915EA30645D9D3D4DAE4FEB1048932DD3AAAA3
+ sha256sums = 57d47a12a76fd92664ae30032cf969284ebac1dfc25bf824999d74b016d51366
+ sha256sums = SKIP
+
+pkgname = libp11-static
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad2bc4bc33c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Robert Falkenberg <robert.falkenberg@tu-dortmund.de>
+# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+# Contributor: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Contributor: kevku <kevku@msn.com>
+# Contributor: Rene Pärts <rene87@hot.ee>
+
+pkgname=libp11-static
+_pkgname=libp11
+pkgver=0.4.11
+pkgrel=1
+pkgdesc="A library implementing a small layer on top of the PKCS11 API (with static libs)"
+arch=('x86_64')
+url="https://github.com/OpenSC/libp11/wiki"
+license=('LGPL')
+depends=('openssl')
+options=('staticlibs')
+provides=("libp11=$pkgver")
+conflicts=('libp11')
+source=("https://github.com/OpenSC/${_pkgname}/releases/download/${_pkgname}-${pkgver}/${_pkgname}-${pkgver}.tar.gz"{,.asc})
+sha256sums=('57d47a12a76fd92664ae30032cf969284ebac1dfc25bf824999d74b016d51366'
+ 'SKIP')
+validpgpkeys=('AC915EA30645D9D3D4DAE4FEB1048932DD3AAAA3')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+