summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomain Bazile2020-07-02 23:51:37 +0200
committerRomain Bazile2020-07-02 23:51:37 +0200
commit9c530ea96625505739e9ffa25621a2247773ca6b (patch)
treec490ef972cf5c095170d4fef1ae73fa99abb0520
parent25a757262fa31c3d23b0559db2cd37e2db17c017 (diff)
downloadaur-9c530ea96625505739e9ffa25621a2247773ca6b.tar.gz
fix GCC10 compilation bug
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
-rw-r--r--skewt.patch12
-rw-r--r--xygrib.install6
4 files changed, 23 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4297a0ceaa7e..e486b2a2f74d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,12 +15,15 @@ pkgbase = xygrib-git
depends = proj
depends = qt5-base
depends = openjpeg2
+ depends = qt5-tools
provides = xygrib
conflicts = xygrib
source = xygrib-git::git+https://github.com/opengribs/XyGrib.git
source = xygrib.install
+ source = skewt.patch
sha1sums = SKIP
sha1sums = 58925746bf6ac941ab34e268517581f1e01e9cff
+ sha1sums = 1fa4cf6b72863c9f33a80946d9f4afe7f855df6a
pkgname = xygrib-git
diff --git a/PKGBUILD b/PKGBUILD
index e3bf81d4c0b7..717f0ed8287f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,12 +10,13 @@ arch=('x86_64' 'aarch64')
license=("GPL3")
conflicts=('xygrib')
provides=('xygrib')
-depends=('libnova' 'qwt' 'proj' 'qt5-base' 'openjpeg2')
+depends=('libnova' 'qwt' 'proj' 'qt5-base' 'openjpeg2' 'qt5-tools')
makedepends=('cmake' 'zlib' 'bzip2' 'libpng')
url="https://opengribs.org/"
-source=("$pkgname::git+https://github.com/opengribs/XyGrib.git" "xygrib.install")
+source=("$pkgname::git+https://github.com/opengribs/XyGrib.git" "xygrib.install" "skewt.patch")
sha1sums=('SKIP'
- '58925746bf6ac941ab34e268517581f1e01e9cff')
+ '58925746bf6ac941ab34e268517581f1e01e9cff'
+ '1fa4cf6b72863c9f33a80946d9f4afe7f855df6a')
pkgver() {
cd $pkgname
@@ -24,6 +25,7 @@ pkgver() {
build() {
cd $pkgname
+ patch --strip=1 -i $srcdir/skewt.patch
mkdir -p build
cd build
cmake ../
diff --git a/skewt.patch b/skewt.patch
new file mode 100644
index 000000000000..7cddef86e103
--- /dev/null
+++ b/skewt.patch
@@ -0,0 +1,12 @@
+diff --git a/src/SkewT.h b/src/SkewT.h
+index c9a23ce..0916681 100644
+--- a/src/SkewT.h
++++ b/src/SkewT.h
+@@ -31,6 +31,7 @@
+ #include <QCheckBox>
+ #include <QThread>
+ #include <QMessageBox>
++#include <QPainterPath>
+
+ class SkewT;
+
diff --git a/xygrib.install b/xygrib.install
index 0a039b4dd254..94973cb92191 100644
--- a/xygrib.install
+++ b/xygrib.install
@@ -1,15 +1,15 @@
post_install() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ gtk-update-icon-cache -q -t -f /usr/share/pixmaps
update-desktop-database -q
}
post_upgrade() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ gtk-update-icon-cache -q -t -f /usr/share/pixmaps
update-desktop-database -q
}
post_remove() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ gtk-update-icon-cache -q -t -f /usr/share/pixmaps
update-desktop-database -q
}