summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBao Trinh2023-04-17 05:50:08 -0500
committerBao Trinh2023-04-17 05:50:08 -0500
commit9c7cadd4aec194e528210052537f0e0f471f5d8b (patch)
tree1f755beee9b595670b7cc01722dbcb88e6d838df
parent4b35af40e7c4626f22049042d780bdfaf212886b (diff)
downloadaur-9c7cadd4aec194e528210052537f0e0f471f5d8b.tar.gz
v2.1.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD26
2 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8a115f70702..27da2ba85518 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = python-autoflake
pkgdesc = Removes unused imports and unused variables
- pkgver = 2.0.2
+ pkgver = 2.1.0
pkgrel = 1
- url = https://github.com/myint/autoflake
+ url = https://github.com/PyCQA/autoflake
arch = any
license = MIT
+ checkdepends = python-pytest
makedepends = python-build
makedepends = python-hatchling
makedepends = python-installer
- makedepends = python-pytest
depends = python
depends = python-pyflakes
depends = python-tomli
- source = https://github.com/myint/autoflake/archive/v2.0.2.tar.gz
- sha256sums = 90fc6f7135047ba523d86d69860b8f63c7fd099f67b369f1d5dce39253ec09b1
+ source = python-autoflake-2.1.0.tar.gz::https://github.com/PyCQA/autoflake/archive/refs/tags/v2.1.0.tar.gz
+ sha256sums = f4ae7902d723f226a2c9654e907cc4534e3ca8e9f0ef4f9baa8cc64e6ecca643
pkgname = python-autoflake
diff --git a/PKGBUILD b/PKGBUILD
index a85e19726a52..b48fc63ff36e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,15 @@
-# Maintainer: pancho horrillo <pancho at pancho dot name>
+# Maintainer: Bao Trinh <qubidt at gmail dot com>
+# Contributor: pancho horrillo <pancho at pancho dot name>
# Contributor: Andrea Orru <andrea at orru dot io>
# Python package author: Steven Myint <UNKNOWN>
-_name=autoflake
+
pkgname=python-autoflake
-pkgver=2.0.2
+_pkgname="${pkgname#python-}"
+pkgver=2.1.0
pkgrel=1
pkgdesc='Removes unused imports and unused variables'
arch=(any)
-url="https://github.com/myint/$_name"
+url="https://github.com/PyCQA/autoflake"
license=("MIT")
depends=(
'python'
@@ -19,24 +21,24 @@ makedepends=(
'python-build'
'python-hatchling'
'python-installer'
- 'python-pytest'
)
-source=("https://github.com/myint/$_name/archive/v${pkgver}.tar.gz")
-sha256sums=('90fc6f7135047ba523d86d69860b8f63c7fd099f67b369f1d5dce39253ec09b1')
+checkdepends=('python-pytest')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/PyCQA/autoflake/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('f4ae7902d723f226a2c9654e907cc4534e3ca8e9f0ef4f9baa8cc64e6ecca643')
build() {
- pwd
- ls -lah
- cd "$srcdir/$_name-$pkgver"
+ cd "${_pkgname}-${pkgver}"
python -m build -nw
}
check() {
- cd "$srcdir/$_name-$pkgver"
+ cd "${_pkgname}-${pkgver}"
pytest
}
package() {
- cd "$srcdir/$_name-$pkgver"
+ cd "${_pkgname}-${pkgver}"
python -m installer -d "$pkgdir" dist/*.whl
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" "README.md"
}