summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron DeVore2015-07-08 11:31:26 -0700
committerAaron DeVore2015-07-08 11:31:26 -0700
commit9c91b804fb2fa6a68cfba03536e4a16de69f772f (patch)
tree338c334cc6528e8befced6a0d6c51b67d993b87a
downloadaur-9c91b804fb2fa6a68cfba03536e4a16de69f772f.tar.gz
Initial import
-rw-r--r--.AURINFO20
-rw-r--r--.SRCINFO22
-rw-r--r--LICENSE20
-rw-r--r--PKGBUILD28
4 files changed, 90 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..68b92472e372
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,20 @@
+pkgbase = wok
+ pkgdesc = Static site generator
+ pkgver = 1.1.1
+ pkgrel = 2
+ url = http://wok.mythmon.com
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-yaml
+ depends = python2-jinja
+ depends = python2-markdown
+ depends = python2-docutils
+ depends = python2-pygments
+ depends = python2-slugify
+ source = http://pypi.python.org/packages/source/w/wok/wok-1.1.1.tar.gz
+ source = LICENSE
+
+pkgname = wok
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21b229fa657a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = wok
+ pkgdesc = Static site generator
+ pkgver = 1.1.1
+ pkgrel = 2
+ url = http://wok.mythmon.com
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-yaml
+ depends = python2-jinja
+ depends = python2-markdown
+ depends = python2-docutils
+ depends = python2-pygments
+ depends = python2-slugify
+ source = http://pypi.python.org/packages/source/w/wok/wok-1.1.1.tar.gz
+ source = LICENSE
+ md5sums = a39df2325317daec09061f983522aca4
+ md5sums = 5c9c57db8a21e4fbe3298502f58a4cd0
+
+pkgname = wok
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..13e494a95484
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,20 @@
+Wok is a static website generator.
+Copyright (C) 2011 Michael Cooper, et al.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of
+this software and associated documentation files (the "Software"), to deal in
+the Software without restriction, including without limitation the rights to
+use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
+of the Software, and to permit persons to whom the Software is furnished to do
+so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+The software is provided "as is", without warranty of any kind, express or
+implied, including but not limited to the warranties of merchantability,
+fitness for a particular purpose and noninfringement. In no event shall the
+authors or copyright holders be liable for any claim, damages or other
+liability, whether in an action of contract, tort or otherwise, arising from,
+out of or in connection with the software or the use or other dealings in the
+software.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0dafc3c9256
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Aaron DeVore <aaron.devore@gmail.com>
+
+pkgname=wok
+pkgver=1.1.1
+pkgrel=2
+pkgdesc="Static site generator"
+url="http://wok.mythmon.com"
+depends=('python2' 'python2-yaml' 'python2-jinja' 'python2-markdown' 'python2-docutils'
+ 'python2-pygments' 'python2-slugify')
+makedepends=('python2-setuptools')
+license=('MIT')
+arch=('any')
+source=("http://pypi.python.org/packages/source/w/wok/wok-$pkgver.tar.gz"
+ LICENSE)
+md5sums=('a39df2325317daec09061f983522aca4'
+ '5c9c57db8a21e4fbe3298502f58a4cd0')
+
+build() {
+ cd "$srcdir/wok-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/wok-$pkgver"
+ install -D -m644 "$srcdir/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}