summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjoshcarp2023-01-27 15:57:05 -0500
committerjoshcarp2023-01-27 15:57:05 -0500
commit9ca4ebafc105825f68419ad294629b5ef1846ba6 (patch)
tree8de9f344b6e67ce1ead26640cb8cd9127a65888a
parent0d68faeae5ace8d3927439622bb4c82e8770cfa4 (diff)
downloadaur-9ca4ebafc105825f68419ad294629b5ef1846ba6.tar.gz
Update to v1.13.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05d8345eae64..8248031ddc05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = buf
pkgdesc = A new way of working with Protocol Buffers
- pkgver = 1.13.0
+ pkgver = 1.13.1
pkgrel = 1
url = https://buf.build
arch = any
license = Apache
makedepends = go
- source = https://github.com/bufbuild/buf/archive/v1.13.0.tar.gz
- sha256sums = 7568666bd4f145443af828745b38f290fb28068735184ec6614e93beb7c09c7d
+ source = https://github.com/bufbuild/buf/archive/v1.13.1.tar.gz
+ sha256sums = bed6990123dc9e419a1d8b2e3fa4e7cc45162f8583a839f0a92d1fddd41fe4fe
pkgname = buf
diff --git a/PKGBUILD b/PKGBUILD
index 6687be25d677..ee96da5d6d24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Buf <bot@buf.build>
# Contributor: Alexander Menzhinsky <amenzhinsky@gmail.com>
pkgname=buf
-pkgver=1.13.0
+pkgver=1.13.1
pkgrel=1
pkgdesc="A new way of working with Protocol Buffers"
arch=("any")
url="https://buf.build"
license=('Apache')
makedepends=('go')
-source=("https://github.com/bufbuild/buf/archive/v1.13.0.tar.gz")
+source=("https://github.com/bufbuild/buf/archive/v1.13.1.tar.gz")
build() {
- cd ${pkgname}-1.13.0
+ cd ${pkgname}-1.13.1
go build -trimpath -buildmode=pie -mod=readonly -modcacherw -buildvcs=false -o . ./cmd/{buf,protoc-gen-buf-lint,protoc-gen-buf-breaking}
./buf completion bash >completion.bash
./buf completion zsh >completion.zsh
@@ -21,13 +21,13 @@ build() {
}
package() {
- install -Dm755 "${pkgname}-1.13.0/buf" "${pkgdir}/usr/bin/buf"
- install -Dm755 "${pkgname}-1.13.0/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
- install -Dm755 "${pkgname}-1.13.0/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
- install -Dm644 "${pkgname}-1.13.0/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
- install -Dm644 "${pkgname}-1.13.0/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
- install -Dm644 "${pkgname}-1.13.0/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
- install -Dm644 "${pkgname}-1.13.0/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
+ install -Dm755 "${pkgname}-1.13.1/buf" "${pkgdir}/usr/bin/buf"
+ install -Dm755 "${pkgname}-1.13.1/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
+ install -Dm755 "${pkgname}-1.13.1/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
+ install -Dm644 "${pkgname}-1.13.1/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
+ install -Dm644 "${pkgname}-1.13.1/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
+ install -Dm644 "${pkgname}-1.13.1/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
+ install -Dm644 "${pkgname}-1.13.1/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
}
-sha256sums=('7568666bd4f145443af828745b38f290fb28068735184ec6614e93beb7c09c7d')
+sha256sums=('bed6990123dc9e419a1d8b2e3fa4e7cc45162f8583a839f0a92d1fddd41fe4fe')