summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustforlxz2022-03-20 01:10:10 +0800
committerjustforlxz2022-03-20 01:10:10 +0800
commit9cc517ade0f98607e7dc700cc30c46aec58a3a70 (patch)
tree3a29df5bfaa8723fd4ac845bc2d0ff0f6e95f4a7
parent0cb27f1bbd503a1d14f3b2dda413e4a843df9a6a (diff)
downloadaur-9cc517ade0f98607e7dc700cc30c46aec58a3a70.tar.gz
update
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7dbdfd426ebb..f49dfd61b07a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = deepin-polkit-agent-git
pkgdesc = Deepin Polkit Agent
- pkgver = 5.5.3.r10.g0def9c0
+ pkgver = 5.5.3.r15.g65afa2e
pkgrel = 1
url = https://github.com/linuxdeepin/dde-polkit-agent
arch = x86_64
+ arch = aarch64
groups = deepin-git
license = GPL3
makedepends = git
@@ -18,7 +19,7 @@ pkgbase = deepin-polkit-agent-git
depends = dtkwidget-git
provides = deepin-polkit-agent
conflicts = deepin-polkit-agent
- source = deepin-polkit-agent-git::git://github.com/linuxdeepin/dde-polkit-agent
+ source = deepin-polkit-agent-git::git+https://github.com/linuxdeepin/dde-polkit-agent
source = fix.patch
sha512sums = SKIP
sha512sums = b02235cece90a01942cd0898cfb85c7eb8fa6f980c4e1d83cfa115baba1599ca878788b5d89338444afe8267c30b11f9279ebda98d3bbc3dd4f3fe03cd1f0572
diff --git a/PKGBUILD b/PKGBUILD
index 562e16dfa359..bca67ace3104 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: justforlxz <justforlxz@gmail.com>
pkgname=deepin-polkit-agent-git
-pkgver=5.5.3.r10.g0def9c0
+pkgver=5.5.3.r15.g65afa2e
pkgrel=1
pkgdesc='Deepin Polkit Agent'
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://github.com/linuxdeepin/dde-polkit-agent"
license=('GPL3')
depends=('deepin-qt-dbus-factory-git' 'startdde-git' 'polkit-qt5' 'dtkwidget-git')
@@ -12,7 +12,7 @@ makedepends=('git' 'polkit-qt5' 'dtkcommon-git' 'dtkwidget-git' 'cmake' 'ninja')
conflicts=('deepin-polkit-agent')
provides=('deepin-polkit-agent')
groups=('deepin-git')
-source=("$pkgname::git://github.com/linuxdeepin/dde-polkit-agent"
+source=("$pkgname::git+https://github.com/linuxdeepin/dde-polkit-agent"
"fix.patch")
sha512sums=('SKIP'
'b02235cece90a01942cd0898cfb85c7eb8fa6f980c4e1d83cfa115baba1599ca878788b5d89338444afe8267c30b11f9279ebda98d3bbc3dd4f3fe03cd1f0572')
@@ -24,6 +24,10 @@ pkgver() {
prepare() {
cd $pkgname
+ if [[ ! -z ${sha} ]];then
+ git checkout -b $sha
+ fi
+
patch -p1 -i ../fix.patch
}