summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2020-05-01 19:35:47 +0000
committerAntonio Rojas2020-05-01 19:35:47 +0000
commit9cccaac9af5c5705b19e946d06f45f64839f02c1 (patch)
tree3f168bb563e1d9d5070c4fbaf356c71633c5e00b
downloadaur-9cccaac9af5c5705b19e946d06f45f64839f02c1.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD49
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d568cabf9ca7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = qtspim
+ pkgdesc = New user interface for spim, a MIPS simulator.
+ pkgver = 9.1.21
+ pkgrel = 1
+ url = http://spimsimulator.sourceforge.net/
+ arch = x86_64
+ license = BSD
+ makedepends = qt5-tools
+ makedepends = subversion
+ makedepends = icu
+ depends = qt5-base
+ source = spimsimulator::svn://svn.code.sf.net/p/spimsimulator/code/#revision=729
+ sha256sums = SKIP
+
+pkgname = qtspim
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bc752d18bb8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
+# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+
+pkgname=qtspim
+pkgver=9.1.21
+pkgrel=1
+pkgdesc="New user interface for spim, a MIPS simulator."
+arch=('x86_64')
+url="http://spimsimulator.sourceforge.net/"
+license=('BSD')
+depends=('qt5-base')
+makedepends=('qt5-tools' 'subversion' 'icu')
+source=("spimsimulator::svn://svn.code.sf.net/p/spimsimulator/code/#revision=729")
+sha256sums=('SKIP')
+
+prepare() {
+ cd spimsimulator/QtSpim
+ sed -r \
+ -e 's/-Wno-write-strings/& -fpermissive/' \
+ -i QtSpim.pro
+ rm parser_yacc.* scanner_lex.*
+}
+
+build() {
+ cd spimsimulator/QtSpim
+
+ qmake
+
+ # Fix Makefile generated by qmake.
+ sed -i 's#$(MOVE) help/qtspim.qhc help/qtspim.qhc;##' Makefile
+
+ make -j1
+}
+
+package() {
+ cd spimsimulator
+
+ install -D QtSpim/QtSpim "$pkgdir/usr/bin/qtspim"
+
+ install -d "$pkgdir/usr/share/qtspim"
+ cp -r QtSpim/help "$pkgdir/usr/share/qtspim"
+
+ install -Dm644 Documentation/spim.man "$pkgdir/usr/share/man/man1/qtspim.1"
+ install -Dm644 Setup/qtspim_debian_deployment/qtspim.desktop \
+ "$pkgdir/usr/share/applications/qtspim.desktop"
+ install -Dm644 Setup/qtspim_debian_deployment/copyright \
+ "$pkgdir/usr/share/licenses/$pkgname/copyright"
+ install -Dm644 Setup/NewIcon48x48.png "$pkgdir/usr/share/qtspim/qtspim.png"
+}