summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPoly2020-03-15 17:55:42 +0100
committerPoly2020-03-15 17:55:42 +0100
commit9cdbdd4a76b99ee0b47e034c78af68df8bd640d4 (patch)
tree0707450bdd929c9fc8633fd0a46b12cf7aad839f
downloadaur-9cdbdd4a76b99ee0b47e034c78af68df8bd640d4.tar.gz
Init
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a915602e9ae1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = yetanotherbar-git
+ pkgdesc = YetAnotherBar is simple gtk based statusbar for i3 with support for CSS
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/PolyMeilex/YetAnotherBar.git
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = rust
+ source = yetanotherbar::git+https://github.com/PolyMeilex/YetAnotherBar.git
+ md5sums = SKIP
+
+pkgname = yetanotherbar-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..29622268aa35
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+yetanotherbar
+*.tar
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f75459e4d3a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: PolyMeilex <bartek.marynczak@op.pl>
+pkgname="yetanotherbar-git"
+pkgver=0.0.1.r0.g80feb5e
+pkgrel=1
+pkgdesc="YetAnotherBar is simple gtk based statusbar for i3 with support for CSS"
+arch=('i686' 'x86_64')
+url="https://github.com/PolyMeilex/YetAnotherBar.git"
+license=('GPL3')
+depends=()
+makedepends=('git' 'rust')
+source=("yetanotherbar::git+https://github.com/PolyMeilex/YetAnotherBar.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/yetanotherbar"
+ git describe --long --tags | sed "s/-/.r/;s/-/./g"
+}
+
+build() {
+ cd "$srcdir/yetanotherbar"
+ cargo build --release --locked
+}
+
+package() {
+ cd "$srcdir/yetanotherbar"
+ install -Dm 755 target/release/yetanotherbar -t "${pkgdir}/usr/bin"
+}