summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-11-06 15:47:45 -0700
committeryochananmarqos2019-11-06 15:47:45 -0700
commit9d0455c847a631eae389c21d69f2dab154f0e5bd (patch)
tree4131bf805cdb18072c83664746679f6c7bf6383d
downloadaur-9d0455c847a631eae389c21d69f2dab154f0e5bd.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
-rwxr-xr-xPyShortcut.desktop7
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc9523197a2f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-pyshortcuts
+ pkgdesc = Create desktop shortcuts to python scripts
+ pkgver = 1.7
+ pkgrel = 1
+ url = https://github.com/newville/pyshortcuts
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-six
+ depends = python-wxpython
+ source = python-pyshortcuts-1.7.tar.gz::https://github.com/newville/pyshortcuts/archive/1.7.tar.gz
+ source = PyShortcut.desktop
+ sha256sums = 1bcba867cfef137ca6fbb188aeb4d30ec4747ed1f6278acca1a757e37c3c671f
+ sha256sums = 8087c2ec7b71de9f0a9e7ef963a6f67d83e33271ef0071b1018ee475998380a5
+
+pkgname = python-pyshortcuts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8afa680613c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
+pkgname=python-pyshortcuts
+pkgver=1.7
+pkgrel=1
+pkgdesc="Create desktop shortcuts to python scripts"
+arch=('any')
+url="https://github.com/newville/pyshortcuts"
+license=('MIT')
+depends=('python-six' 'python-wxpython')
+makedepends=('python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/newville/pyshortcuts/archive/$pkgver.tar.gz"
+ 'PyShortcut.desktop')
+sha256sums=('1bcba867cfef137ca6fbb188aeb4d30ec4747ed1f6278acca1a757e37c3c671f'
+ '8087c2ec7b71de9f0a9e7ef963a6f67d83e33271ef0071b1018ee475998380a5')
+
+build() {
+ cd "pyshortcuts-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "pyshortcuts-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir/PyShortcut.desktop" "$pkgdir/usr/share/applications/PyShortcut.desktop"
+}
diff --git a/PyShortcut.desktop b/PyShortcut.desktop
new file mode 100755
index 000000000000..22fd657832eb
--- /dev/null
+++ b/PyShortcut.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=PyShortcut
+Type=Application
+Comment=PyShortcut
+Terminal=false
+Icon=/usr/lib/python3.7/site-packages/pyshortcuts/icons/py.ico
+Exec=/usr/sbin/python /usr/bin/pyshortcut --wxgui