summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgustawho2017-11-17 07:47:36 -0600
committergustawho2017-11-17 07:47:36 -0600
commit9d0478bd7e92a38ac9a44513ecf12195672d64d4 (patch)
treede9b0d83424c49a3aad5ecfda7fc7f4e699605a6
downloadaur-9d0478bd7e92a38ac9a44513ecf12195672d64d4.tar.gz
Initial upload
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
-rw-r--r--beamer-theme-torino-git.install6
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25b7b47e8257
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = beamer-theme-torino-git
+ pkgdesc = A pretty theme for LaTeX Beamer
+ pkgver = r3.d664ecb
+ pkgrel = 1
+ url = https://github.com/bbatsov/beamer-torino-theme
+ install = beamer-theme-torino-git.install
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = texlive-core
+ provides = beamer-theme-torino
+ conflicts = beamer-theme-torino
+ source = git://github.com/bbatsov/beamer-torino-theme.git
+ md5sums = SKIP
+
+pkgname = beamer-theme-torino-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e27a2c09de4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
+
+pkgname=beamer-theme-torino-git
+pkgver=r3.d664ecb
+pkgrel=1
+pkgdesc="A pretty theme for LaTeX Beamer"
+arch=(any)
+url="https://github.com/bbatsov/beamer-torino-theme"
+license=('unknown')
+depends=('texlive-core')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install="${pkgname}.install"
+source=('git://github.com/bbatsov/beamer-torino-theme.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir"/beamer-torino-theme
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir"/beamer-torino-theme
+ mkdir -p $pkgdir/usr/share/texmf-dist/tex/latex/beamer/themes/{color,inner,outer,theme}
+
+ install -m644 themes/color/* \
+ "$pkgdir/usr/share/texmf-dist/tex/latex/beamer/themes/color/"
+
+ install -m644 themes/inner/beamerinnerthemefancy.sty \
+ "$pkgdir/usr/share/texmf-dist/tex/latex/beamer/themes/inner/"
+
+ install -m644 themes/outer/beamerouterthemedecolines.sty \
+ "$pkgdir/usr/share/texmf-dist/tex/latex/beamer/themes/outer/"
+
+ install -m644 themes/theme/beamerthemeTorino.sty \
+ "$pkgdir/usr/share/texmf-dist/tex/latex/beamer/themes/theme/"
+}
diff --git a/beamer-theme-torino-git.install b/beamer-theme-torino-git.install
new file mode 100644
index 000000000000..840662286799
--- /dev/null
+++ b/beamer-theme-torino-git.install
@@ -0,0 +1,6 @@
+post_install() {
+ mktexlsr
+}
+post_remove() {
+ mktexlsr
+} \ No newline at end of file