summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArley2019-09-08 00:24:54 -0500
committerArley2019-09-08 00:24:54 -0500
commit9d0f0ca1d4d0d62ab214592f35adf1b77ee2b3fa (patch)
treeccfe42f5bd851edbfe88a184333a889e0a97119b
downloadaur-9d0f0ca1d4d0d62ab214592f35adf1b77ee2b3fa.tar.gz
init commit
-rw-r--r--.SRCINFO20
-rw-r--r--LICENSE24
-rw-r--r--PKGBUILD32
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c988ebd5f467
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = genie-systemd
+ pkgdesc = A quick way into a systemd "bottle" for WSL
+ pkgver = 1.10
+ pkgrel = 1
+ url = https://github.com/arkane-systems/genie
+ arch = x86_64
+ license = custom:The Unlicense
+ depends = daemonize
+ depends = dotnet-runtime
+ depends = dotnet-host
+ depends = hostess
+ provides = genie-systemd
+ conflicts = genie-systemd
+ source = https://github.com/arkane-systems/genie/releases/download/1.10/genie.tar.gz
+ source = LICENSE
+ sha256sums = 02ba197ba39d8be19afde3182ce901b67b2d1412625c0c52238b9a83d4c49401
+ sha256sums = 88d9b4eb60579c191ec391ca04c16130572d7eedc4a86daa58bf28c6e14c9bcd
+
+pkgname = genie-systemd
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..cf1ab25da034
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,24 @@
+This is free and unencumbered software released into the public domain.
+
+Anyone is free to copy, modify, publish, use, compile, sell, or
+distribute this software, either in source code form or as a compiled
+binary, for any purpose, commercial or non-commercial, and by any
+means.
+
+In jurisdictions that recognize copyright laws, the author or authors
+of this software dedicate any and all copyright interest in the
+software to the public domain. We make this dedication for the benefit
+of the public at large and to the detriment of our heirs and
+successors. We intend this dedication to be an overt act of
+relinquishment in perpetuity of all present and future rights to this
+software under copyright law.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
+
+For more information, please refer to <http://unlicense.org>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb68d988ef83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Arley Henostroza <arllk[at]gmail[dot]com>
+
+pkgname=genie-systemd
+_pkgname=genie
+pkgver=1.10
+pkgrel=1
+pkgdesc="A quick way into a systemd \"bottle\" for WSL"
+arch=('x86_64')
+url="https://github.com/arkane-systems/genie"
+license=('custom:The Unlicense')
+depends=('daemonize' 'dotnet-runtime' 'dotnet-host' 'hostess')
+conflicts=('genie-systemd')
+provides=('genie-systemd')
+source=("${url}/releases/download/${pkgver}/${_pkgname}.tar.gz"
+ 'LICENSE')
+sha256sums=('02ba197ba39d8be19afde3182ce901b67b2d1412625c0c52238b9a83d4c49401'
+ '88d9b4eb60579c191ec391ca04c16130572d7eedc4a86daa58bf28c6e14c9bcd')
+
+prepare() {
+ tar -xzf ${_pkgname}.tar.gz
+}
+
+package() {
+ cd "systemd-genie/usr/bin/"
+ install -Dm 4755 -o root "genie" -t "$pkgdir/usr/bin"
+ install -Dm 644 -o root "genie.dll" -t "$pkgdir/usr/bin"
+ install -Dm 744 -o root "Linux.ProcessManager.dll" -t "$pkgdir/usr/bin"
+ install -Dm 744 -o root "System.CommandLine.dll" -t "$pkgdir/usr/bin"
+ install -Dm 744 -o root "Tmds.LibC.dll" -t "$pkgdir/usr/bin"
+ install -Dm 644 -o root "genie.runtimeconfig.json" -t "$pkgdir/usr/bin"
+ install -Dm 644 "${srcdir}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}