summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 23:27:38 -0600
committerBrian Bidulock2015-06-10 23:27:38 -0600
commit9d1192fac751fb2017649c7604c62a0c04a7643b (patch)
treebbb11b5c3f3fd0d8803c84390ef3419465cafff7
downloadaur-9d1192fac751fb2017649c7604c62a0c04a7643b.tar.gz
initial version
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..45961763ef64
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = xdg-traymenu
+ pkgdesc = XDG compliant system tray and root menu generator
+ pkgver = 0.01.40
+ pkgrel = 1
+ url = https://github.com/bbidulock/xdg-traymenu
+ arch = any
+ groups = xde
+ license = GPL
+ makedepends = git
+ depends = perl-xml-sax
+ optdepends = perl-gtk2-unique: for xdg-traymenu
+ optdepends = xde-theme: style menus and wm detection
+ optdepends = xdg-launch: startup notification for menu items
+ options = !emptydirs
+ source = xdg-traymenu::git+https://github.com/bbidulock/xdg-traymenu.git
+ md5sums = SKIP
+
+pkgname = xdg-traymenu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..557b532f1dcb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+
+pkgname=xdg-traymenu
+pkgver=0.01.40
+pkgrel=1
+pkgdesc="XDG compliant system tray and root menu generator"
+arch=('any')
+url="https://github.com/bbidulock/xdg-traymenu"
+groups=('xde')
+license=('GPL')
+depends=('perl-xml-sax')
+optdepends=('perl-gtk2-unique: for xdg-traymenu'
+ 'xde-theme: style menus and wm detection'
+ 'xdg-launch: startup notification for menu items')
+makedepends=('git')
+options=('!emptydirs')
+source=("$pkgname::git+https://github.com/bbidulock/xdg-traymenu.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags|sed 's,[-_],.,g;s,\.g.*$,,'
+}
+
+build() {
+ cd $pkgname
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" INSTALLVENDORSCRIPT=/usr/bin install
+ find $pkgdir -name '.packlist' -delete
+ find $pkgdir -name '*.pod' -delete
+}
+
+# vim:set ts=2 sw=2 et: