summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzneix2022-05-11 23:40:56 +0200
committerzneix2022-05-11 23:40:56 +0200
commit9d136722c7ab50895e3a84a70e4969e57cad5ba6 (patch)
tree10ac1c85145fe8de1612ae0509d2e7d1824d22ea
parent5acc96c6d450fcaee8732c3cc587ded1a90e96a1 (diff)
downloadaur-9d136722c7ab50895e3a84a70e4969e57cad5ba6.tar.gz
Add git submodules
Add missing cmake-sanitizers Add new magic_enum - see note in PKGBUILD (taken from upstream package, since it's the exact same situation as there)
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--Makefile4
-rw-r--r--PKGBUILD11
4 files changed, 19 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46f501a3ade4..326e9c27d379 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chatterino2-7tv-git
pkgdesc = A fork of Chatterino2 with built-in support for 7tv emotes
- pkgver = r3487.dbd99e4c
+ pkgver = r3610.d2e9c105
pkgrel = 1
url = https://github.com/SevenTV/chatterino7
install = chatterino2-7tv-git.install
@@ -33,6 +33,10 @@ pkgbase = chatterino2-7tv-git
source = git+https://github.com/Tencent/rapidjson
source = git+https://github.com/Chatterino/qtkeychain
source = git+https://github.com/zaphoyd/websocketpp
+ source = git+https://github.com/arsenm/sanitizers-cmake
+ source = git+https://github.com/Neargye/magic_enum
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
index 53412d460847..774eed5d89a1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -16,3 +16,5 @@ serialize/
settings/
signals/
websocketpp/
+sanitizers-cmake/
+magic_enum/
diff --git a/Makefile b/Makefile
index 2b5486bd2228..ec062957a391 100644
--- a/Makefile
+++ b/Makefile
@@ -19,4 +19,6 @@ clean:
serialize \
rapidjson \
qtkeychain \
- websocketpp
+ websocketpp \
+ sanitizers-cmake \
+ magic_enum
diff --git a/PKGBUILD b/PKGBUILD
index 5f05699909b5..0504f6bc3821 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=chatterino2-7tv-git
_pkgname=chatterino7
-pkgver=r3487.dbd99e4c
+pkgver=r3610.d2e9c105
pkgrel=1
pkgdesc='A fork of Chatterino2 with built-in support for 7tv emotes'
arch=('any')
@@ -25,7 +25,9 @@ source=("git+https://github.com/SevenTV/chatterino7"
"git+https://github.com/pajlada/serialize"
"git+https://github.com/Tencent/rapidjson"
"git+https://github.com/Chatterino/qtkeychain"
- "git+https://github.com/zaphoyd/websocketpp")
+ "git+https://github.com/zaphoyd/websocketpp"
+ "git+https://github.com/arsenm/sanitizers-cmake"
+ "git+https://github.com/Neargye/magic_enum")
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -35,6 +37,8 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -54,6 +58,9 @@ prepare () {
git config submodule.rapidjson $srcdir/$_pkgname/lib/rapidjson
git config submodule.qtkeychain $srcdir/$_pkgname/lib/qtkeychain
git config submodule.websocketpp $srcdir/$_pkgname/lib/websocketpp
+ git config submodule.sanitizers-cmake $srcdir/$_pkgname/lib/sanitizers-cmake
+ # We can't set the local directory of this submodule as we have no way of accessing the config name `submodule.magic_enum` because underscores are actually not allowed.
+ #git config submodule.magic_enum $srcdir/$_pkgname/lib/magic_enum
git submodule update
}