summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorckath2019-08-31 20:36:16 +0200
committerckath2019-08-31 20:36:16 +0200
commit9d20fe51bc22ddaf20c0b92a0dc0ac5db66dfb62 (patch)
tree5ea23449e997f98d3fe3bd2c29d0990ef255d5c1
downloadaur-9d20fe51bc22ddaf20c0b92a0dc0ac5db66dfb62.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--fuf.install5
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dfa3db2d3813
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = fuf
+ pkgdesc = Fairly Usable cli Filebrowser.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/ckath/fuf
+ install = fuf.install
+ arch = any
+ license = MIT
+ makedepends = git
+ optdepends = w3m: image previews
+ provides = fuf
+ conflicts = fuf-git
+ source = fuf::git+https://github.com/ckath/fuf.git#tag=v0.1
+ md5sums = SKIP
+
+pkgname = fuf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..907229cc2ffb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Ckat <ckat@teknik.io>
+pkgname=fuf
+pkgver=0.1
+pkgrel=1
+pkgdesc='Fairly Usable cli Filebrowser.'
+arch=('any')
+url=https://github.com/ckath/fuf
+license=('MIT')
+makedepends=('git')
+optdepends=('w3m: image previews')
+conflicts=('fuf-git')
+provides=('fuf')
+install=fuf.install
+source=("$pkgname::git+https://github.com/ckath/fuf.git#tag=v$pkgver")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 fuf "$pkgdir/usr/bin/fuf"
+ install -Dm755 scripts/open "$pkgdir/usr/lib/$pkgname/open"
+ install -Dm755 scripts/preview "$pkgdir/usr/lib/$pkgname/preview"
+
+}
diff --git a/fuf.install b/fuf.install
new file mode 100644
index 000000000000..8e0063dccb57
--- /dev/null
+++ b/fuf.install
@@ -0,0 +1,5 @@
+post_install() {
+ printf "==> copy scripts for editing:\n"
+ printf "\t mkdir ~/.config/fuf && cp /usr/lib/fuf/{open,preview} ~/.config/fuf\n"
+ printf "\n==> for more info see: https://github.com/Ckath/fuf\n"
+}