summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMasaki Haruka2020-11-11 18:03:26 +0900
committerMasaki Haruka2020-11-11 18:03:26 +0900
commit9d2a704514fb346a6227484e755b3f12cc95687e (patch)
treeee52828db79d5bc1e25467e85f22dd6eb6407cd2
parente3fc7c88d3d530b270a9079eb72f0f171b71d76c (diff)
downloadaur-9d2a704514fb346a6227484e755b3f12cc95687e.tar.gz
Use JAIST mirror.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63f6626d658c..7d722173c58d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mozc-ut-unified
pkgver = 2.25.4180.102.20201110
- pkgrel = 1
+ pkgrel = 2
url = https://osdn.net/users/utuhiro/pf/utuhiro/files/
arch = i686
arch = x86_64
@@ -27,7 +27,7 @@ pkgbase = mozc-ut-unified
source = https://download.fcitx-im.org/fcitx-mozc/fcitx-mozc-icon.tar.gz
source = https://www.post.japanpost.jp/zipcode/dl/kogaki/zip/ken_all.zip
source = https://www.post.japanpost.jp/zipcode/dl/jigyosyo/zip/jigyosyo.zip
- source = https://osdn.net/frs/chamber_redir.php?m=ymu&f=%2Fusers%2F26%2F26897%2Fmozcdic-ut-20201110.1.tar.bz2
+ source = https://osdn.net/frs/chamber_redir.php?m=jaist&f=%2Fusers%2F26%2F26897%2Fmozcdic-ut-20201110.1.tar.bz2
sha1sums = 96f5f005c8083533ba42c70570e85c5ca1a207a3
sha1sums = 824ae3a8fdd2c2bf2e667212e41312ffb2560640
sha1sums = 9c89be7df9c5e8cb0bc20b3c4b39bf7e82686770
@@ -40,7 +40,7 @@ pkgbase = mozc-ut-unified
sha1sums = e91e7f67c48f59cd67787e5e6af98946e9a53b1c
pkgname = mozc-ut-unified
- pkgdesc = A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input) with NEologd UT dictionary and UT2 dictionary (all dictionaries enabled.)
+ pkgdesc = A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input) with NEologd UT dictionary and UT2 dictionary (default dictionaries.)
arch = i686
arch = x86_64
depends = qt5-base
@@ -53,9 +53,11 @@ pkgname = mozc-ut-unified
conflicts = fcitx-mozc-neologd-ut
conflicts = mozc-neologd-ut
conflicts = fcitx-mozc-neologd-ut+ut2
+ conflicts = mozc-ut-unified-full
+ conflicts = fcitx-mozc-ut-unified-full
pkgname = fcitx-mozc-ut-unified
- pkgdesc = Fcitx engine module for Mozc with NEologd UT dictionary and UT2 dictionary (all dictionaries enabled.)
+ pkgdesc = Fcitx engine module for Mozc with NEologd UT dictionary and UT2 dictionary (default dictionaries.)
arch = i686
arch = x86_64
depends = mozc-ut-unified=2.25.4180.102.20201110
@@ -69,4 +71,6 @@ pkgname = fcitx-mozc-ut-unified
conflicts = fcitx-mozc-neologd-ut
conflicts = mozc-neologd-ut
conflicts = fcitx-mozc-neologd-ut+ut2
+ conflicts = mozc-ut-unified-full
+ conflicts = fcitx-mozc-ut-unified-full
diff --git a/PKGBUILD b/PKGBUILD
index b914213512cf..7700c1951939 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ _mozcver=2.25.4180.102
_fcitxver=20201110
_utdicdate=20201110
pkgver=${_mozcver}.${_utdicdate}
-pkgrel=1
+pkgrel=2
pkgname=mozc-ut-unified
true && pkgname=('mozc-ut-unified' 'fcitx-mozc-ut-unified')
@@ -29,7 +29,7 @@ source=(
https://download.fcitx-im.org/fcitx-mozc/fcitx-mozc-icon.tar.gz
https://www.post.japanpost.jp/zipcode/dl/kogaki/zip/ken_all.zip
https://www.post.japanpost.jp/zipcode/dl/jigyosyo/zip/jigyosyo.zip
- 'https://osdn.net/frs/chamber_redir.php?m=ymu&f=%2Fusers%2F26%2F26897%2Fmozcdic-ut-20201110.1.tar.bz2'
+ 'https://osdn.net/frs/chamber_redir.php?m=jaist&f=%2Fusers%2F26%2F26897%2Fmozcdic-ut-20201110.1.tar.bz2'
)
sha1sums=(
@@ -67,7 +67,7 @@ prepare() {
sed -i -e 's/-lc++//' src/gyp/common.gypi
# Add UT dictionary
- cat ${srcdir}/mozcdic-ut-${_utdicdate}.${pkgrel}/mozcdic*-ut-*.txt >> src/data/dictionary_oss/dictionary00.txt
+ cat ${srcdir}/mozcdic-ut-${_utdicdate}.*/mozcdic*-ut-*.txt >> src/data/dictionary_oss/dictionary00.txt
}
build() {
@@ -80,10 +80,10 @@ build() {
}
package_mozc-ut-unified() {
- pkgdesc="A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input) with NEologd UT dictionary and UT2 dictionary (all dictionaries enabled.)"
+ pkgdesc="A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input) with NEologd UT dictionary and UT2 dictionary (default dictionaries.)"
arch=('i686' 'x86_64')
depends=('qt5-base')
- conflicts=('fcitx-mozc' 'mozc' 'fcitx-mozc-ut2' 'mozc-ut2' 'fcitx-mozc-ut' 'mozc-ut' 'fcitx-mozc-neologd-ut' 'mozc-neologd-ut' 'fcitx-mozc-neologd-ut+ut2')
+ conflicts=('fcitx-mozc' 'mozc' 'fcitx-mozc-ut2' 'mozc-ut2' 'fcitx-mozc-ut' 'mozc-ut' 'fcitx-mozc-neologd-ut' 'mozc-neologd-ut' 'fcitx-mozc-neologd-ut+ut2' 'mozc-ut-unified-full' 'fcitx-mozc-ut-unified-full')
cd mozc-${_mozcver}/src
install -D -m 755 out_linux/${_bldtype}/mozc_server "${pkgdir}/usr/lib/mozc/mozc_server"
install -m 755 out_linux/${_bldtype}/mozc_tool "${pkgdir}/usr/lib/mozc/mozc_tool"
@@ -93,10 +93,10 @@ package_mozc-ut-unified() {
}
package_fcitx-mozc-ut-unified() {
- pkgdesc="Fcitx engine module for Mozc with NEologd UT dictionary and UT2 dictionary (all dictionaries enabled.)"
+ pkgdesc="Fcitx engine module for Mozc with NEologd UT dictionary and UT2 dictionary (default dictionaries.)"
arch=('i686' 'x86_64')
depends=("mozc-ut-unified=${pkgver}" 'fcitx')
- conflicts=('fcitx-mozc' 'mozc' 'fcitx-mozc-ut2' 'mozc-ut2' 'fcitx-mozc-ut' 'mozc-ut' 'fcitx-mozc-neologd-ut' 'mozc-neologd-ut' 'fcitx-mozc-neologd-ut+ut2')
+ conflicts=('fcitx-mozc' 'mozc' 'fcitx-mozc-ut2' 'mozc-ut2' 'fcitx-mozc-ut' 'mozc-ut' 'fcitx-mozc-neologd-ut' 'mozc-neologd-ut' 'fcitx-mozc-neologd-ut+ut2' 'mozc-ut-unified-full' 'fcitx-mozc-ut-unified-full')
cd mozc-${_mozcver}/src
for mofile in out_linux/${_bldtype}/gen/unix/fcitx/po/*.mo