summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Squartini2019-05-04 11:54:01 +0900
committerNicola Squartini2019-05-04 11:54:01 +0900
commit9d4aa22f76c15aa4bbe0b211c0f33c850cfa5457 (patch)
treef0b6928de1744f5720245235d5558bf0fff0e1da
parente7acb05d8f6761131543736c463a4ee0d38b2f98 (diff)
downloadaur-9d4aa22f76c15aa4bbe0b211c0f33c850cfa5457.tar.gz
Update to 1.0.3
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--grin-server.toml10
3 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdf952c38cdb..112f718e19d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = grin
pkgdesc = Minimal implementation of the MimbleWimble protocol
- pkgver = 1.0.0
+ pkgver = 1.0.3
pkgrel = 1
url = https://github.com/mimblewimble/grin
arch = i686
@@ -11,12 +11,12 @@ pkgbase = grin
makedepends = rust
depends = ncurses
backup = etc/grin/server.toml
- source = git+https://github.com/mimblewimble/grin.git#commit=e7485ab5f1ad5160a42c4230bb523ca3558e7adc
+ source = git+https://github.com/mimblewimble/grin.git#commit=4f52209cd01c90066683df59e3629d6d93bf94f0
source = grin-server.service
source = grin-server.toml
sha256sums = SKIP
sha256sums = 5a9b2c30bd95d8ccb4666dcc97b2811c4b5ec501162b6178a1850b5b2fc95de9
- sha256sums = 8c8bcd780443b19b1947e57610830c2deaa4e15c799bed4c0c68477efb53a62a
+ sha256sums = 4478b8ecf0f7d3e9519bec0f03f969b7b4f3247f7abb5dd8bc25b2e6a5cbb39f
pkgname = grin
diff --git a/PKGBUILD b/PKGBUILD
index cefc60084d68..a710cbe9d4c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Nicola Squartini <tensor5@gmail.com>
pkgname=grin
-pkgver=1.0.0
-_commit=e7485ab5f1ad5160a42c4230bb523ca3558e7adc
+pkgver=1.0.3
+_commit=4f52209cd01c90066683df59e3629d6d93bf94f0
pkgrel=1
pkgdesc='Minimal implementation of the MimbleWimble protocol'
arch=('i686' 'x86_64')
@@ -16,7 +16,7 @@ source=("git+https://github.com/mimblewimble/grin.git#commit=${_commit}"
'grin-server.toml')
sha256sums=('SKIP'
'5a9b2c30bd95d8ccb4666dcc97b2811c4b5ec501162b6178a1850b5b2fc95de9'
- '8c8bcd780443b19b1947e57610830c2deaa4e15c799bed4c0c68477efb53a62a')
+ '4478b8ecf0f7d3e9519bec0f03f969b7b4f3247f7abb5dd8bc25b2e6a5cbb39f')
build() {
cd ${pkgname}
diff --git a/grin-server.toml b/grin-server.toml
index 9e32138ba4a5..2c44659efd4c 100644
--- a/grin-server.toml
+++ b/grin-server.toml
@@ -36,7 +36,8 @@ api_secret_path = "/var/lib/grin/main/.api_secret"
#parameters used for mining as well as wallet output coinbase maturity. Can be:
#AutomatedTesting - For CI builds and instant blockchain creation
#UserTesting - For regular user testing (cuckoo 16)
-#Floonet - For the long term Floonet test network
+#Floonet - For the long term floonet test network
+#Mainnet - For mainnet
chain_type = "Mainnet"
#the chain validation mode, defines how often (if at all) we
@@ -127,7 +128,7 @@ max_pool_size = 50000
max_stempool_size = 50000
#maximum total weight of transactions that can get selected to build a block
-mineable_max_weight = 39976
+mineable_max_weight = 40000
#########################################
@@ -188,7 +189,7 @@ stdout_log_level = "Warning"
log_to_file = true
#log level for file: Error, Warning, Info, Debug, Trace
-file_log_level = "Debug"
+file_log_level = "Info"
#log file path
log_file_path = "/var/log/grin/main/server.log"
@@ -200,3 +201,6 @@ log_file_append = true
#comment it to disable log rotation
log_max_size = 16777216
+#maximum count of the log files to rotate over
+log_max_files = 32
+