summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoripochto2021-12-02 13:58:12 +0300
committeripochto2021-12-02 13:58:12 +0300
commit9d6864a2b6591bd039486afd4bf6d432f13bfff6 (patch)
tree06610d7f725e933d2bbfe51c1405530c85c34977
parent16fe2a866302d018d941790e39806c387c2029e5 (diff)
downloadaur-9d6864a2b6591bd039486afd4bf6d432f13bfff6.tar.gz
added optdepends. cleanup.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD27
2 files changed, 21 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e627b7c81cf8..9123c856b3c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = war1gus-git
- pkgdesc = Warcraft1 Mod that allows you to play Warcraft1 with the Stratagus engine (development version)
- pkgver = 3.1.3.r817.592656a_20211117
+ pkgdesc = Warcraft1 Mod that allows you to play Warcraft1 with the Stratagus engine (dev version)
+ pkgver = 3.1.3.r848.e2a55e3_20211202
pkgrel = 1
url = https://github.com/Wargus/war1gus
arch = i686
@@ -12,8 +12,8 @@ pkgbase = war1gus-git
depends = stratagus-git
depends = ffmpeg
depends = innoextract
- provides = war1gus-git
- provides = war1gus
+ optdepends = fluidsynth: midi music support
+ optdepends = soundfont-fluid: sound font for midi music support
conflicts = war1gus
source = war1gus-git::git://github.com/Wargus/war1gus.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 26d0b2b38bb2..78109da85f44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,29 @@
# Maintainer: ipochto <ipochto@gmail.com>
pkgname=war1gus-git
-pkgver=3.1.3.r817.592656a_20211117
+pkgver=3.1.3.r848.e2a55e3_20211202
pkgrel=1
-pkgdesc="Warcraft1 Mod that allows you to play Warcraft1 with the Stratagus engine (development version)"
+pkgdesc="Warcraft1 Mod that allows you to play Warcraft1 with the Stratagus engine (dev version)"
arch=("i686" "x86_64")
url="https://github.com/Wargus/war1gus"
license=('GPL')
-depends=('stratagus-git' 'ffmpeg' 'innoextract')
-makedepends=('git' 'cmake' 'imagemagick')
-
+makedepends=(
+ 'git'
+ 'cmake'
+ 'imagemagick'
+)
+depends=(
+ 'stratagus-git'
+ 'ffmpeg'
+ 'innoextract'
+)
+optdepends=(
+ 'fluidsynth: midi music support'
+ 'soundfont-fluid: sound font for midi music support'
+)
+conflicts=('war1gus')
source=("${pkgname}::git://github.com/Wargus/war1gus.git")
md5sums=('SKIP')
-provides=(${pkgname}
- 'war1gus')
-conflicts=('war1gus')
pkgver() {
cd "$srcdir/${pkgname}"
@@ -24,9 +33,7 @@ pkgver() {
build() {
cd ${srcdir}
-
cmake ${pkgname} -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DGAMEDIR=/usr/bin -Bbuild
-
make -C build
}