summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Maftei2020-09-20 09:00:05 +0300
committerDan Maftei2020-09-20 09:00:05 +0300
commit9d6989553bab7ee05c43d560b159147e42a5fc73 (patch)
tree8bf8a1c87b4eb8b0fc5682fb2b2900afbcd7b489
parentc2f2c8eb0d8ccc93b9db6f667119bc1054023c35 (diff)
downloadaur-9d6989553bab7ee05c43d560b159147e42a5fc73.tar.gz
Upstream checksum changed.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acd6763a4f50..01953d5793ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = molden
pkgdesc = A program for molecular and electronic structure visualization
- pkgver = 6.3
+ pkgver = 6.5
pkgrel = 1
url = http://www.cmbi.ru.nl/molden/
arch = i686
@@ -17,8 +17,8 @@ pkgbase = molden
optdepends = openbabel: to create 2D images of the molecules in a .sdf file
optdepends = wget: to fetch PDB from rcsb.org
provides = molden
- source = ftp://ftp.cmbi.umcn.nl/pub/molgraph/molden/molden6.3.tar.gz
- md5sums = 92d6aa6442c3e67571b4494553b0d180
+ source = ftp://ftp.cmbi.umcn.nl/pub/molgraph/molden/molden6.5.tar.gz
+ md5sums = 97bfffd55e166ca3a9fbddee111993ff
pkgname = molden
diff --git a/PKGBUILD b/PKGBUILD
index 598d2236d18a..f3eeaf70c9c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Dan Maftei <dan.maftei@gmail.com>
pkgname="molden"
-pkgver=6.3
+pkgver=6.5
pkgrel=1
pkgdesc="A program for molecular and electronic structure visualization"
arch=('i686' 'x86_64')
@@ -31,25 +31,25 @@ source=(
"ftp://ftp.cmbi.umcn.nl/pub/molgraph/molden/$pkgname$pkgver.tar.gz"
)
noextract=()
-md5sums=('92d6aa6442c3e67571b4494553b0d180')
+md5sums=('97bfffd55e166ca3a9fbddee111993ff')
build() {
cd "molden$pkgver"
# Patch Makefile for surf utility to reflect
# the replacement of missing makedepend
- sed -i 's/@.*makedepend.*$/@ \$(CC) \$(INCLUDE) -M \$(SRCS) \> makedep/' surf/Makefile
+ sed -i 's/@.*makedepend.*$/@ \$(CC) \$(INCLUDE) -M \$(SRCS) \> makedep/' src/surf/Makefile
# Patch to compile with gfortran 10
# Contributed by Panadestein on 5/31/2020
sed -i 's/FFLAGS = -g ${AFLAG}/& -fallow-argument-mismatch/g' makefile
- sed -i 's/FFLAGS = -c -g -ffast-math -funroll-loops -O3/& -fallow-argument-mismatch/g' ambfor/makefile
+ sed -i 's/FFLAGS = -c -g -ffast-math -funroll-loops -O3/& -fallow-argument-mismatch/g' src/ambfor/makefile
make
}
package() {
cd "molden$pkgver"
- install -t "$pkgdir/usr/bin/" -Dm755 molden gmolden
- install -t "$pkgdir/usr/lib/$pkgname/" -Dm755 ambfor/ambfor ambfor/ambmd surf/surf
+ install -t "$pkgdir/usr/bin/" -Dm755 bin/{molden,gmolden}
+ install -t "$pkgdir/usr/lib/$pkgname/" -Dm755 src/ambfor/ambfor src/ambfor/ambmd src/surf/surf
install -t "$pkgdir/usr/share/doc/$pkgname" -Dm755 doc/figures.ps.Z doc/manual.ps.Z doc/manual.txt.Z
install -t "$pkgdir/usr/share/licenses/$pkgname/" -Dm755 CopyRight COMMERCIAL_LICENSE REGISTER
}