summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrevel2019-12-17 03:45:07 +0100
committerrevel2019-12-17 03:45:07 +0100
commit9d8be652456bed92a21f3bbb666464b17c83b826 (patch)
treecd60f12b0aaa3a6009f4c8122741bc0a5adda868
parent3d964094d86888a3c0fb5d155f83b42c23f2be23 (diff)
downloadaur-9d8be652456bed92a21f3bbb666464b17c83b826.tar.gz
- fixes plugin path
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--plugin_path.patch12
3 files changed, 22 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9683083c2bdc..2cc84b2743e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = edb-debugger
pkgdesc = EDB (Evan's Debugger) is a cross platform AArch32/x86/x86-64 debugger, inspired by Ollydbg.
pkgver = 1.1.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.codef00.com/projects#debugger
arch = i686
arch = x86_64
@@ -14,8 +14,10 @@ pkgbase = edb-debugger
optdepends = graphviz
source = https://github.com/eteran/edb-debugger/releases/download/1.1.0/edb-debugger-1.1.0.tgz
source = edb.desktop
+ source = plugin_path.patch
sha256sums = f13de8fd3f26fa1210fb0ff50ff756c2de8de51e75770a57aca35df06d6a0187
sha256sums = f3e725642c6b87d5a7fd25331a9560d4f9803c22566875b722bc27e275f311a6
+ sha256sums = f216174d68ef7c26f29a58e409261c5b36af6593fe1778f6b2ad284095662b10
pkgname = edb-debugger
diff --git a/PKGBUILD b/PKGBUILD
index b775d3e033d1..4f1abb328077 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=edb-debugger
pkgver=1.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="EDB (Evan's Debugger) is a cross platform AArch32/x86/x86-64 debugger, inspired by Ollydbg."
arch=('i686' 'x86_64')
url='http://www.codef00.com/projects#debugger'
@@ -13,19 +13,22 @@ depends=('qt5-xmlpatterns' 'qt5-svg' 'capstone>=3.0')
makedepends=('boost>=1.35.0' 'cmake')
optdepends=('graphviz')
source=("https://github.com/eteran/edb-debugger/releases/download/$pkgver/edb-debugger-$pkgver.tgz"
- 'edb.desktop')
+ 'edb.desktop'
+ 'plugin_path.patch')
sha256sums=('f13de8fd3f26fa1210fb0ff50ff756c2de8de51e75770a57aca35df06d6a0187'
- 'f3e725642c6b87d5a7fd25331a9560d4f9803c22566875b722bc27e275f311a6')
+ 'f3e725642c6b87d5a7fd25331a9560d4f9803c22566875b722bc27e275f311a6'
+ 'f216174d68ef7c26f29a58e409261c5b36af6593fe1778f6b2ad284095662b10')
prepare() {
cd "edb-debugger"
+ patch -p1 -i ../plugin_path.patch
}
build() {
cd "edb-debugger"
[ ! -d build ] && mkdir build
cd build
- cmake -DCMAKE_INSTALL_PREFIX="$pkgdir/usr/" ..
+ cmake -DCMAKE_INSTALL_PREFIX="$pkgdir/usr/" -DDEFAULT_PLUGIN_PATH="/usr/lib/edb/" ..
make
}
diff --git a/plugin_path.patch b/plugin_path.patch
new file mode 100644
index 000000000000..3c97b74c691c
--- /dev/null
+++ b/plugin_path.patch
@@ -0,0 +1,12 @@
+diff -ruN 1/src/CMakeLists.txt 2/src/CMakeLists.txt
+--- 1/src/CMakeLists.txt 2019-11-24 04:07:27.000000000 +0100
++++ 2/src/CMakeLists.txt 2019-12-17 03:06:05.118631427 +0100
+@@ -219,7 +219,7 @@
+
+ target_compile_definitions(edb PRIVATE
+ -DGIT_BRANCH=${GIT_BRANCH}
+- -DDEFAULT_PLUGIN_PATH=\"${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/edb\"
++ -DDEFAULT_PLUGIN_PATH=\"${DEFAULT_PLUGIN_PATH}\"
+ )
+
+ target_link_libraries(edb