summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFélix Piédallu2022-11-15 11:30:26 +0100
committerFélix Piédallu2022-11-15 11:30:26 +0100
commit9d96a2f5402fcac8fe12ca37dad3549a70fe684a (patch)
treea5db7c22815b1497d3eb3ee6a6df6f1d460cc98f
parent1dcbcad06c62d7a3166b15191dafa69dd475f453 (diff)
downloadaur-9d96a2f5402fcac8fe12ca37dad3549a70fe684a.tar.gz
Initial commit with syncthing-gtk org as remote
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD48
3 files changed, 44 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9bbeaa96fc0b..bdef9e306ef8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,24 @@
pkgbase = syncthing-gtk
- pkgdesc = GTK3 based GUI and notification area icon for Syncthing
- pkgver = 0.9.4.4
- pkgrel = 2
+ pkgdesc = GTK3 based GUI and notification area icon for Syncthing.
+ pkgver = 0.9.4.4.2
+ pkgrel = 1
epoch = 1
- url = https://github.com/syncthing/syncthing-gtk
+ url = https://github.com/syncthing-gtk/syncthing-gtk
arch = any
license = GPL2
- makedepends = python2-setuptools
+ makedepends = python-setuptools
+ makedepends = git
depends = syncthing>=0.14.50
depends = gtk3
depends = libnotify
- depends = python2-bcrypt
- depends = python2-cairo
- depends = python2-dateutil
- depends = python2-gobject
- source = syncthing-gtk-0.9.4.4.tar.gz::https://github.com/syncthing/syncthing-gtk/archive/v0.9.4.4.tar.gz
+ depends = python-bcrypt
+ depends = python-cairo
+ depends = python-dateutil
+ depends = python-gobject
+ replaces = syncthing-gtk-python3
+ source = syncthing-gtk-0.9.4.4.2.tar.gz::https://github.com/syncthing-gtk/syncthing-gtk/archive/v0.9.4.4.2.tar.gz
source = kde-statusicon.patch
- sha256sums = 896ddaaba4ad0b8f090c5a381a28b3da759932314562cdd50ca288543b03ddcc
+ sha256sums = 24d34699acd58af0933f51476fe3af655238788be52c4f1c96c6d0ebb1706703
sha256sums = 109d8c970045e60251fc64865f05322b23a0995ee6725be02905941cb3a1ae0d
pkgname = syncthing-gtk
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7baf6caf2f00
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+*.pkg*
+/syncthing-gtk/
diff --git a/PKGBUILD b/PKGBUILD
index 089615b22545..de232570bdf4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,42 @@
-# Maintainer: Jaroslav Lichtblau <svetlemodry@archlinux.org>
+# Maintainer: Salamandar <felix@piedallu.me>
+# Contributor: Jaroslav Lichtblau <svetlemodry@archlinux.org>
# Contributor: Martin Wimpress <code@flexion.org>
# Contributor: kozec <kozec at kozec dot com>
pkgname=syncthing-gtk
-pkgver=0.9.4.4
-pkgrel=2
-epoch=1
-pkgdesc='GTK3 based GUI and notification area icon for Syncthing'
+pkgver=0.9.4.4.2
+pkgrel=1
+pkgdesc='GTK3 based GUI and notification area icon for Syncthing.'
arch=('any')
-url='https://github.com/syncthing/syncthing-gtk'
+url='https://github.com/syncthing-gtk/syncthing-gtk'
license=('GPL2')
-depends=('syncthing>=0.14.50' 'gtk3' 'libnotify' 'python2-bcrypt'
- 'python2-cairo' 'python2-dateutil' 'python2-gobject')
-makedepends=('python2-setuptools')
-source=($pkgname-$pkgver.tar.gz::https://github.com/syncthing/$pkgname/archive/v$pkgver.tar.gz
- kde-statusicon.patch)
-sha256sums=('896ddaaba4ad0b8f090c5a381a28b3da759932314562cdd50ca288543b03ddcc'
- '109d8c970045e60251fc64865f05322b23a0995ee6725be02905941cb3a1ae0d')
+replaces=( 'syncthing-gtk-python3' )
+depends=(
+ 'syncthing>=0.14.50' 'gtk3' 'libnotify'
+ 'python-bcrypt' 'python-cairo' 'python-dateutil' 'python-gobject'
+)
+makedepends=('python-setuptools' 'git')
+source=(
+ "$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+ kde-statusicon.patch
+)
+sha256sums=(
+ '24d34699acd58af0933f51476fe3af655238788be52c4f1c96c6d0ebb1706703'
+ '109d8c970045e60251fc64865f05322b23a0995ee6725be02905941cb3a1ae0d'
+)
prepare() {
- cd $pkgname-$pkgver
-
- # Enable Gtk.StatusIcon in KDE
- patch -Np1 -i ../kde-statusicon.patch
+ cd "$pkgname-$pkgver"
+ # Enable Gtk.StatusIcon in KDE
+ patch -Np1 -i ../kde-statusicon.patch
}
build() {
- cd $pkgname-$pkgver
- python2 setup.py build
+ cd "$pkgname-$pkgver"
+ python3 setup.py build
}
package() {
- cd $pkgname-$pkgver
- python2 setup.py install --root="${pkgdir}" --optimize=1
+ cd "$pkgname-$pkgver"
+ python3 setup.py install --root="$pkgdir" --optimize=1
}