summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaël Guillemenot2015-06-11 15:46:55 +0200
committerLaël Guillemenot2015-06-11 15:46:55 +0200
commit9d9aafa00decbdb1aed73099a87fa67bb20b658d (patch)
treed03d9651ebcf9fcf22cfa49e362c7c6b5ec47b78
downloadaur-9d9aafa00decbdb1aed73099a87fa67bb20b658d.tar.gz
Récupération en provenance de aur
-rw-r--r--.AURINFO28
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD52
-rw-r--r--modules.conf13
-rw-r--r--ocsinventory-agent1
-rw-r--r--ocsinventory-agent.cfg1
-rw-r--r--ocsinventory-agent.install9
7 files changed, 136 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..53786bcb76fc
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,28 @@
+pkgbase = ocsinventory-agent
+ pkgdesc = Hardware and software inventory tool (client)
+ pkgver = 2.1.1
+ pkgrel = 1
+ url = http://www.ocsinventory-ng.org
+ install = ocsinventory-agent.install
+ arch = any
+ license = GPL
+ depends = dmidecode
+ depends = pciutils
+ depends = perl-crypt-ssleay
+ depends = perl-xml-sax
+ depends = perl-libwww
+ depends = perl-net-ip
+ depends = perl-xml-namespacesupport
+ depends = perl-xml-simple
+ depends = perl-proc-daemon
+ depends = perl-proc-pid-file
+ depends = perl-net-ssleay
+ optdepends = smartmontools
+ source = https://launchpad.net/ocsinventory-unix-agent/stable-2.1/2.1.1/+download/Ocsinventory-Unix-Agent-2.1.1.tar.gz
+ source = modules.conf
+ source = ocsinventory-agent
+ source = ocsinventory-agent.cfg
+ backup = etc/ocsinventory/ocsinventory-agent.cfg
+
+pkgname = ocsinventory-agent
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66e149afa395
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = ocsinventory-agent
+ pkgdesc = Hardware and software inventory tool (client)
+ pkgver = 2.1.1
+ pkgrel = 1
+ url = http://www.ocsinventory-ng.org
+ install = ocsinventory-agent.install
+ arch = any
+ license = GPL
+ depends = dmidecode
+ depends = pciutils
+ depends = perl-crypt-ssleay
+ depends = perl-xml-sax
+ depends = perl-libwww
+ depends = perl-net-ip
+ depends = perl-xml-namespacesupport
+ depends = perl-xml-simple
+ depends = perl-proc-daemon
+ depends = perl-proc-pid-file
+ depends = perl-net-ssleay
+ optdepends = smartmontools
+ backup = etc/ocsinventory/ocsinventory-agent.cfg
+ source = https://launchpad.net/ocsinventory-unix-agent/stable-2.1/2.1.1/+download/Ocsinventory-Unix-Agent-2.1.1.tar.gz
+ source = modules.conf
+ source = ocsinventory-agent
+ source = ocsinventory-agent.cfg
+ md5sums = 195960e048bfa77badc2a3df382a5a88
+ md5sums = a2a8a3ee7018d5681403088dcd3d2c2e
+ md5sums = 9419012794e5e134bc152cfd388d63e7
+ md5sums = 3be05b06c7a6e269d9a4c74dcf239d19
+
+pkgname = ocsinventory-agent
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1420cbbbb104
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Contributor: Elis Hughes <elishughes@googlemail.com>
+# Contributor: djerome <jerome _at_ j2ze dot org>
+# Maintainer: zeppelinlg <zeppelinlg@gmail.com>
+
+pkgname=ocsinventory-agent
+pkgver=2.1.1
+pkgrel=1
+pkgdesc="Hardware and software inventory tool (client)"
+arch=('any')
+url="http://www.ocsinventory-ng.org"
+license=('GPL')
+depends=('dmidecode' 'pciutils' 'perl-crypt-ssleay' 'perl-xml-sax'
+ 'perl-libwww' 'perl-net-ip' 'perl-xml-namespacesupport' 'perl-xml-simple'
+ 'perl-proc-daemon' 'perl-proc-pid-file' 'perl-net-ssleay')
+optdepends=('smartmontools')
+install=${pkgname}.install
+backup=('etc/ocsinventory/ocsinventory-agent.cfg')
+source=("https://launchpad.net/ocsinventory-unix-agent/stable-2.1/$pkgver/+download/Ocsinventory-Unix-Agent-$pkgver.tar.gz"
+ "modules.conf" "ocsinventory-agent" "ocsinventory-agent.cfg")
+md5sums=('195960e048bfa77badc2a3df382a5a88'
+ 'a2a8a3ee7018d5681403088dcd3d2c2e'
+ '9419012794e5e134bc152cfd388d63e7'
+ '3be05b06c7a6e269d9a4c74dcf239d19')
+
+build() {
+ cd "$srcdir/Ocsinventory-Unix-Agent-$pkgver"
+
+ perl Makefile.PL
+ make || return 1
+ rm run-postinst
+}
+
+package() {
+ mkdir -p ${pkgdir}/var/lib/ocsinventory-agent
+ mkdir -p ${pkgdir}/var/log/ocsinventory-agent
+ mkdir -p ${pkgdir}/var/run
+
+ cd "$srcdir/Ocsinventory-Unix-Agent-$pkgver"
+
+ make DESTDIR=${pkgdir} install
+
+ /usr/bin/find ${pkgdir} -name '.packlist' -delete
+ /usr/bin/find ${pkgdir} -name '*.pod' -delete
+
+ cd "$srcdir"
+ install -D -m644 ocsinventory-agent.cfg "${pkgdir}/etc/ocsinventory/ocsinventory-agent.cfg"
+ install -D -m644 modules.conf "${pkgdir}/etc/ocsinventory/modules.conf"
+ install -D -m744 -D ocsinventory-agent "${pkgdir}/etc/cron.d/ocsinventory-agent"
+
+ cd "$srcdir/Ocsinventory-Unix-Agent-$pkgver"
+ install -D -m755 ocsinventory-agent "${pkgdir}"/usr/bin/ocsinventory-agent
+}
diff --git a/modules.conf b/modules.conf
new file mode 100644
index 000000000000..3b1f795a7a82
--- /dev/null
+++ b/modules.conf
@@ -0,0 +1,13 @@
+# this list of module will be load by the at run time
+# to check its syntax do:
+# #perl modules.conf
+# You must have NO error. Else the content will be ignored
+# This mechanism goal it to keep compatibility with 'plugin'
+# created for the previous linux_agent.
+# The new unified_agent have its own extension system that allow
+# user to add new information easily.
+
+use Ocsinventory::Agent::Option::Download;
+
+# DO NO REMOVE the 1;
+1;
diff --git a/ocsinventory-agent b/ocsinventory-agent
new file mode 100644
index 000000000000..66cb83335b7d
--- /dev/null
+++ b/ocsinventory-agent
@@ -0,0 +1 @@
+43 2 * * * root /usr/bin/ocsinventory-agent --lazy > /dev/null 2>&1
diff --git a/ocsinventory-agent.cfg b/ocsinventory-agent.cfg
new file mode 100644
index 000000000000..30dec1a71c4f
--- /dev/null
+++ b/ocsinventory-agent.cfg
@@ -0,0 +1 @@
+server=servername.yourdomain.com
diff --git a/ocsinventory-agent.install b/ocsinventory-agent.install
new file mode 100644
index 000000000000..cecdf0695096
--- /dev/null
+++ b/ocsinventory-agent.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "Edit /etc/ocsinventory/ocsinventory-agent.cfg with your server details."
+}
+pre_upgrade() {
+ mv /etc/ocsinventory/ocsinventory-agent.cfg /etc/ocsinventory/ocsinventory-agent.cfg.OLD
+}
+post_upgrade() {
+ mv /etc/ocsinventory/ocsinventory-agent.cfg.OLD /etc/ocsinventory/ocsinventory-agent.cfg
+}