summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Duerr2017-11-11 17:21:25 +0100
committerChristian Duerr2017-11-11 17:21:25 +0100
commit9dabbfc5e5bc5cf158a28bf4ee27156e11a0f624 (patch)
treedb15600168f3c016904606dc77f9f3b2ac72f9f1
downloadaur-9dabbfc5e5bc5cf158a28bf4ee27156e11a0f624.tar.gz
Initial commit
Created PKGBUILD for weechat with python3 support instead of python2. Everything else should be the same as the default weechat package in the official repos. SRCINFO has been autogenerated. This package pulls from git automatically. So it should always be up-to-date.
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD43
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6931ab1d2373
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = weechat-python3-git
+ pkgdesc = Weechat compiled with Python3 instead of Python2, experimental
+ pkgver = 1.9.433.g58a6b564e
+ pkgrel = 1
+ url = https://github.com/weechat/weechat
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ makedepends = perl
+ makedepends = python3
+ makedepends = lua
+ makedepends = tcl
+ makedepends = ruby
+ makedepends = aspell
+ makedepends = guile2.0
+ makedepends = asciidoctor
+ depends = gnutls
+ depends = curl
+ depends = libgcrypt
+ optdepends = perl
+ optdepends = python3
+ optdepends = lua
+ optdepends = tcl
+ optdepends = ruby
+ optdepends = aspell
+ optdepends = guile2.0
+ source = git+https://github.com/weechat/weechat
+ sha512sums = SKIP
+
+pkgname = weechat-python3-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9002691e00a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# $Id$
+# Maintainer : Christian Duerr <contact@christianduerr.com>
+# Original PKGBUILD by
+# - Christian Rebischke <Chris.Rebischke@archlinux.org>
+# - Giovanni Scafora <giovanni@archlinux.org>
+# - lucke <lucke at o2 dot pl>
+
+pkgname=weechat-python3-git
+pkgver=1.9.433.g58a6b564e
+pkgrel=1
+pkgdesc="Weechat compiled with Python3 instead of Python2, experimental"
+arch=('i686' 'x86_64')
+url="https://github.com/weechat/weechat"
+license=('GPL')
+depends=('gnutls' 'curl' 'libgcrypt')
+makedepends=('git' 'cmake' 'perl' 'python3' 'lua' 'tcl' 'ruby' 'aspell' 'guile2.0' 'asciidoctor')
+optdepends=('perl' 'python3' 'lua' 'tcl' 'ruby' 'aspell' 'guile2.0')
+source=("git+$url")
+sha512sums=('SKIP')
+
+_gitname='weechat'
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git describe --tags | sed 's/-/./g' | tail -c +2
+}
+
+build() {
+ cd "$_gitname"
+ cmake -Wno-dev "$srcdir/$_gitname" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.6m.so \
+ -DENABLE_MAN=ON \
+ -DENABLE_DOC=ON \
+ -DENABLE_PYTHON3=ON
+ make
+}
+
+package() {
+ cd "$_gitname"
+ make DESTDIR="${pkgdir}" install
+}