summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-07-28 16:07:41 +0800
committerSainnhepark2020-07-28 16:07:41 +0800
commit9dccb206b43eb0cd761da541e4ec64c01d3958d0 (patch)
treec8cb788deedc83ad037033fdbe52ce3fa10b793c
parent9ab34522d11641737babfc7a8f9a4be58ca148df (diff)
downloadaur-9dccb206b43eb0cd761da541e4ec64c01d3958d0.tar.gz
update build()
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed2b9cacf632..3694f430ed93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,12 +25,16 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
yarn install --frozen-lockfile
- npm prune --production
+ yarn pack --frozen-lockfile --production
+ tar xvf *.tgz
+ rm *.tgz
+ cd package
+ yarn install --frozen-lockfile --production
}
package() {
- cd "${srcdir}/${_extname}"
- find autoload lib/*.js node_modules package.json plugin -type f -exec \
+ cd "${srcdir}/${_extname}/package"
+ find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
- rm -rf node_modules
+ rm -rf "${srcdir}/${_extname}/package"
}