summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2023-06-02 22:19:27 +0200
committerMichel Zou2023-06-02 22:19:27 +0200
commit9dd8ee48ec3fac959591c8eb10a27744cf03f03a (patch)
tree2f37865aa084ed56d75f34d18736b4776de6e0ed
parent2acc19e6b54c5a49f155d40a010ae6100dbe971c (diff)
downloadaur-9dd8ee48ec3fac959591c8eb10a27744cf03f03a.tar.gz
2.37.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 15 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3c37796a649..79e175f2620a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
pkgbase = psp-binutils
pkgdesc = A set of programs to assemble and manipulate binary and object files (psp)
- pkgver = 2.23.2
+ pkgver = 2.37.0
pkgrel = 1
url = https://www.gnu.org/software/binutils/
arch = x86_64
- groups = psp
license = GPL
- makedepends = gcc
+ makedepends = git
+ depends = glibc
+ depends = libelf
depends = zlib
- depends = flex
+ depends = python
options = !buildflags
options = !strip
options = staticlibs
- source = https://ftp.gnu.org/pub/gnu/binutils/binutils-2.23.2.tar.bz2
- source = binutils-2.23.2-PSP.patch
- sha256sums = fe914e56fed7a9ec2eb45274b1f2e14b0d8b4f41906a5194eac6883cfe5c1097
- sha256sums = 155d7499dd65d496ec076dc71d93db9c0c2f9cdf3faae8671d969675346bf4c9
+ source = binutils-2.37.0::git+https://github.com/pspdev/binutils-gdb.git#branch=allegrex-v2.37.0
+ sha256sums = SKIP
pkgname = psp-binutils
-
diff --git a/PKGBUILD b/PKGBUILD
index 3a98fbb83aef..d4c59eadf5e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,21 @@
pkgname=psp-binutils
-pkgver=2.23.2
+pkgver=2.37.0
pkgrel=1
pkgdesc="A set of programs to assemble and manipulate binary and object files (psp)"
arch=(x86_64)
url="https://www.gnu.org/software/binutils/"
license=('GPL')
-groups=('psp')
-depends=('zlib' 'flex')
-makedepends=('gcc')
+depends=('glibc' 'libelf' 'zlib' 'python')
+makedepends=('git')
options=('!buildflags' '!strip' 'staticlibs')
-source=("https://ftp.gnu.org/pub/gnu/binutils/binutils-$pkgver.tar.bz2"
- "binutils-$pkgver-PSP.patch")
-sha256sums=('fe914e56fed7a9ec2eb45274b1f2e14b0d8b4f41906a5194eac6883cfe5c1097'
- '155d7499dd65d496ec076dc71d93db9c0c2f9cdf3faae8671d969675346bf4c9')
-
-prepare ()
-{
- cd "$srcdir/binutils-$pkgver"
- rm -f include/opcode/vfpu.h ld/emulparams/elf_mipsallegrexel_psp.sh ld/scripttempl/elf_psp.sc
- patch -p1 -i "$srcdir"/binutils-${pkgver}-PSP.patch
-}
+source=(binutils-$pkgver::git+https://github.com/pspdev/binutils-gdb.git#branch=allegrex-v${pkgver})
+sha256sums=('SKIP')
build()
{
cd "$srcdir/binutils-$pkgver"
mkdir -p build-psp && pushd build-psp
- ../configure --prefix=/usr --target=psp --enable-install-libbfd \
- --enable-plugins --disable-werror --with-system-zlib
+ ../configure --prefix=/usr --target=psp --enable-plugins --disable-werror --with-system-zlib --enable-deterministic-archives
make
}
@@ -35,8 +24,7 @@ package()
cd "$srcdir/binutils-$pkgver/build-psp"
make install DESTDIR="$pkgdir"
rm -r "$pkgdir"/usr/share
- cp -r "$pkgdir"/usr/*-linux-gnu/psp "$pkgdir"/usr
- rm -r "$pkgdir"/usr/*-linux-gnu
- rm -r "$pkgdir"/usr/lib
+ rm "$pkgdir"/usr/lib/bfd-plugins/libdep.so
+ rm "$pkgdir"/usr/include/gdb/jit-reader.h
}